aboutsummaryrefslogtreecommitdiffstats
path: root/packages/netkit-telnet/netkit-telnet_0.17.bb
diff options
context:
space:
mode:
authorHolger Hans Peter Freyther <zecke@selfish.org>2008-11-23 22:48:56 +0100
committerHolger Hans Peter Freyther <zecke@selfish.org>2008-11-23 23:25:14 +0100
commit269716a27d3334806c3d44365b4aae4f29c79c48 (patch)
tree7a9a6dc300bd2ef72aabf4daec5f58fbb03f20e2 /packages/netkit-telnet/netkit-telnet_0.17.bb
parent59f5a9c741bba79e6ebf8e6527142aeeb8ea9236 (diff)
downloadopenembedded-269716a27d3334806c3d44365b4aae4f29c79c48.tar.gz
netkit-telnet: Add a telnet package...
telnetd does not compile with the debian patch, telnet compiles let us use that. This is not using update-alternatives as I think it is not necessary as this is the only telnet provider we have. The "buildsystem" is horrible... kick the configure to not run tests...
Diffstat (limited to 'packages/netkit-telnet/netkit-telnet_0.17.bb')
-rw-r--r--packages/netkit-telnet/netkit-telnet_0.17.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/netkit-telnet/netkit-telnet_0.17.bb b/packages/netkit-telnet/netkit-telnet_0.17.bb
new file mode 100644
index 0000000000..f5ac239039
--- /dev/null
+++ b/packages/netkit-telnet/netkit-telnet_0.17.bb
@@ -0,0 +1,27 @@
+SECTION = "base"
+DESCRIPTION = "netkit-telnet includes the telnet daemon and client."
+DEPENDS = "ncurses"
+LICENSE = "BSD"
+PR = "r0"
+
+SRC_URI = "ftp://ftp.uk.linux.org/pub/linux/Networking/netkit/netkit-telnet-${PV}.tar.gz \
+ file://netkit-telnet-debian_0.17-36.diff;patch=1 \
+ file://cross-compile.patch;patch=1 "
+
+do_configure () {
+ ./configure --prefix=${prefix}
+
+ # Inject our ldflags into the config... it is not horning them otherwise
+ echo "LDFLAGS=${LDFLAGS}" > MCONFIG
+}
+
+
+do_compile () {
+ oe_runmake 'CC=${CC}' 'LD=${LD}' 'LDFLAGS=${LDFLAGS}' SUB=telnet
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 telnet/telnet ${D}${bindir}/telnet
+}
+