aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mplayer
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-05-30 09:50:51 +0000
committerKoen Kooi <koen@openembedded.org>2007-05-30 09:50:51 +0000
commit1a241c914a27ede849021c4c4cb5f408a22cab53 (patch)
treeb2475bf03916ea31e0266a11976e64448f0429e1 /packages/mplayer
parent801b33435917f1f3307616ad0ff908776e31f3ea (diff)
downloadopenembedded-1a241c914a27ede849021c4c4cb5f408a22cab53.tar.gz
mplayer 1.0rc1: sync with svn version for pxa optimizations
Diffstat (limited to 'packages/mplayer')
-rw-r--r--packages/mplayer/mplayer_0.0+1.0rc1.bb17
1 files changed, 14 insertions, 3 deletions
diff --git a/packages/mplayer/mplayer_0.0+1.0rc1.bb b/packages/mplayer/mplayer_0.0+1.0rc1.bb
index 2910cbd0a4..34fe1ac123 100644
--- a/packages/mplayer/mplayer_0.0+1.0rc1.bb
+++ b/packages/mplayer/mplayer_0.0+1.0rc1.bb
@@ -34,7 +34,7 @@ PACKAGE_ARCH_mencoder_collie = "collie"
RCONFLICTS_${PN} = "mplayer-atty"
RREPLACES_${PN} = "mplayer-atty"
-PR = "r12"
+PR = "r13"
PARALLEL_MAKE = ""
@@ -177,13 +177,24 @@ EXTRA_OECONF = " \
EXTRA_OECONF_append_arm = " --disable-decoder=vorbis_decoder \
--disable-encoder=vorbis_encoder"
-EXTRA_OECONF_append_c7x0 = " --enable-w100 --enable-imageon "
-EXTRA_OECONF_append_hx4700 = " --enable-imageon "
EXTRA_OECONF_append_progear = " --disable-sse --disable-3dnow --disable-mmxext --disable-sse2"
+
+#enable support for the ati imageon series (w100 and w3220)
+EXTRA_OECONF_append_c7x0 = " --enable-w100 "
+EXTRA_OECONF_append_hx4700 = " --enable-imageon "
+
+#enable pxa270 overlay support
EXTRA_OECONF_append_spitz = " --enable-pxa "
+EXTRA_OECONF_append_a780 = " --enable-pxa "
+#build with support for the iwmmxt instruction support (pxa270 and up)
TARGET_CC_ARCH_spitz = "-march=iwmmxt -mtune=iwmmxt"
PACKAGE_ARCH_spitz = "iwmmxt"
+TARGET_CC_ARCH_a780 = "-march=iwmmxt -mtune=iwmmxt"
+PACKAGE_ARCH_a780 = "iwmmxt"
+TARGET_CC_ARCH_hx4700 = "-march=iwmmxt -mtune=iwmmxt"
+PACKAGE_ARCH_hx4700= "iwmmxt"
+
do_configure() {
cp ${WORKDIR}/vo_w100.c ${S}/libvo