aboutsummaryrefslogtreecommitdiffstats
path: root/packages/mplayer/files
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-12-06 09:35:40 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-12-06 09:35:40 +0000
commit71b645d6d468556b98ea362591e317289e823dac (patch)
tree5af6a0614bda2555467251004dfb1c4990bf0403 /packages/mplayer/files
parentc484a94ef3b9bc3e42f06b5157086c4309591e69 (diff)
downloadopenembedded-71b645d6d468556b98ea362591e317289e823dac.tar.gz
mplayer_0.0+1.0rc1.bb : add latest version of mplayer, fixing versioning
to meet OE policy. A couple of patches have been rediffed and two Makefile patches dropped as what they did is now in the Makefiles in question.
Diffstat (limited to 'packages/mplayer/files')
-rw-r--r--packages/mplayer/files/Makefile.patch22
-rw-r--r--packages/mplayer/files/libmpcodecs-ogg-include.patch13
-rw-r--r--packages/mplayer/files/libmpdemux-ogg-include.patch13
-rw-r--r--packages/mplayer/files/w100-mplayer.patch15
4 files changed, 18 insertions, 45 deletions
diff --git a/packages/mplayer/files/Makefile.patch b/packages/mplayer/files/Makefile.patch
index b9b68491c5..f0464b9176 100644
--- a/packages/mplayer/files/Makefile.patch
+++ b/packages/mplayer/files/Makefile.patch
@@ -1,15 +1,13 @@
-Index: MPlayer-1.0pre8/Makefile
+Index: MPlayer-1.0rc1/Makefile
===================================================================
---- MPlayer-1.0pre8.orig/Makefile
-+++ MPlayer-1.0pre8/Makefile
-@@ -438,8 +438,8 @@ codecs2html: mp_msg.o
- $(CC) -DCODECS2HTML codec-cfg.c mp_msg.o -o $@
+--- MPlayer-1.0rc1.orig/Makefile
++++ MPlayer-1.0rc1/Makefile
+@@ -399,7 +399,7 @@ osdep/mplayer-rc.o: osdep/mplayer.rc
+ windres -o $@ osdep/mplayer.rc
- $(PRG_CFG): codec-cfg.c codec-cfg.h help_mp.h
-- $(HOST_CC) $(HOST_CFLAGS) -I. codec-cfg.c -o $(PRG_CFG) \
-- -DCODECS2HTML $(EXTRA_LIB) $(EXTRA_INC)
-+ $(BUILD_CC) -Ilibmpdemux -Iloader -Ilibvo -I. codec-cfg.c -o $(PRG_CFG) \
-+ -DCODECS2HTML
+ codec-cfg: codec-cfg.c codec-cfg.h help_mp.h
+- $(HOST_CC) -I. -DCODECS2HTML codec-cfg.c -o $@
++ $(BUILD_CC) -I. -DCODECS2HTML codec-cfg.c -o $@
- install: $(ALL_PRG)
- ifeq ($(VIDIX),yes)
+ codecs.conf.h: codec-cfg etc/codecs.conf
+ ./codec-cfg ./etc/codecs.conf > $@
diff --git a/packages/mplayer/files/libmpcodecs-ogg-include.patch b/packages/mplayer/files/libmpcodecs-ogg-include.patch
deleted file mode 100644
index 619c4b0cd2..0000000000
--- a/packages/mplayer/files/libmpcodecs-ogg-include.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- MPlayer-1.0pre8/libmpcodecs/Makefile.orig 2006-06-30 23:26:33.000000000 +0100
-+++ MPlayer-1.0pre8/libmpcodecs/Makefile 2006-06-30 23:28:52.000000000 +0100
-@@ -267,8 +267,8 @@
- SRCS2=$(ENCODER_SRCS)
- OBJS2=$(SRCS2:.c=.o)
-
--CFLAGS = $(OPTFLAGS) \
-- -I. -I.. \
-+CFLAGS = -I.. $(OPTFLAGS) \
-+ -I. \
- -Inative \
- -I../libmpdemux \
- -I../loader \
diff --git a/packages/mplayer/files/libmpdemux-ogg-include.patch b/packages/mplayer/files/libmpdemux-ogg-include.patch
deleted file mode 100644
index 541f4a03ee..0000000000
--- a/packages/mplayer/files/libmpdemux-ogg-include.patch
+++ /dev/null
@@ -1,13 +0,0 @@
---- MPlayer-1.0pre8/libmpdemux/Makefile.orig 2006-06-30 23:26:49.000000000 +0100
-+++ MPlayer-1.0pre8/libmpdemux/Makefile 2006-06-30 23:27:10.000000000 +0100
-@@ -156,8 +156,8 @@
-
- OBJS = $(SRCS:.c=.o)
- OBJS += $(CPLUSPLUSSRCS:.cpp=.o)
--INCLUDE = -I.. -I../loader $(CSS_INC) $(EXTRA_INC) $(LIBAV_INC)
--CFLAGS = $(OPTFLAGS) $(INCLUDE) $(XMMS_CFLAGS) $(CDPARANOIA_INC) $(DVB_INC)
-+INCLUDE = -I../loader $(CSS_INC) $(EXTRA_INC) $(LIBAV_INC)
-+CFLAGS = -I.. $(OPTFLAGS) $(INCLUDE) $(XMMS_CFLAGS) $(CDPARANOIA_INC) $(DVB_INC)
- CPLUSPLUSFLAGS = $(CFLAGS) $(CPLUSPLUSINCLUDE) -D__STDC_LIMIT_MACROS
- CPLUSPLUS = $(CC)
-
diff --git a/packages/mplayer/files/w100-mplayer.patch b/packages/mplayer/files/w100-mplayer.patch
index 4bed6326d1..8ce37d014c 100644
--- a/packages/mplayer/files/w100-mplayer.patch
+++ b/packages/mplayer/files/w100-mplayer.patch
@@ -1,6 +1,8 @@
---- mplayer_20060519/mplayer.c.orig 2006-05-30 12:31:01.000000000 +0100
-+++ mplayer_20060519/mplayer.c 2006-05-30 12:33:41.000000000 +0100
-@@ -628,6 +628,18 @@
+Index: MPlayer-1.0rc1/mplayer.c
+===================================================================
+--- MPlayer-1.0rc1.orig/mplayer.c
++++ MPlayer-1.0rc1/mplayer.c
+@@ -807,6 +807,17 @@ static void exit_sighandler(int x){
exit_player(NULL);
}
@@ -15,11 +17,10 @@
+ }
+}
+
-+
- //extern void write_avi_header_1(FILE *f,int fcc,float fps,int width,int height);
-
extern void mp_input_register_options(m_config_t* cfg);
-@@ -2732,6 +2744,9 @@
+
+ #include "mixer.h"
+@@ -3216,6 +3227,9 @@ current_module = NULL;
#endif
#endif