aboutsummaryrefslogtreecommitdiffstats
path: root/packages/meta
diff options
context:
space:
mode:
authorJohn Lee <john_lee@openmoko.org>2008-01-17 08:51:49 +0000
committerOpenmoko anonymizer key <devel@lists.openmoko.org>2008-01-17 08:51:49 +0000
commit048ace2a52af79397c783867a0fe2a37d671baf4 (patch)
tree1754762fc241a576e73c1c40f3044a0b500e6633 /packages/meta
parent3ae494f2e5497197beebdcf02af92f892928aadc (diff)
downloadopenembedded-048ace2a52af79397c783867a0fe2a37d671baf4.tar.gz
(Merge OM mtn modification back into mainline)
Add ability to find the directory of parent package if the child package is of different arch.
Diffstat (limited to 'packages/meta')
-rw-r--r--packages/meta/meta-toolchain.bb13
1 files changed, 10 insertions, 3 deletions
diff --git a/packages/meta/meta-toolchain.bb b/packages/meta/meta-toolchain.bb
index fc029505c3..923844ef8c 100644
--- a/packages/meta/meta-toolchain.bb
+++ b/packages/meta/meta-toolchain.bb
@@ -1,7 +1,7 @@
DESCRIPTION = "Meta package for building a installable toolchain"
LICENSE = "MIT"
DEPENDS = "ipkg-native ipkg-utils-native fakeroot-native sed-native"
-PR = "r1"
+PR = "r2"
inherit sdk meta
@@ -75,10 +75,17 @@ do_populate_sdk() {
for arch in $revipkgarchs; do
pkgnames=${DEPLOY_DIR_IPK}/$arch/${pkg}_*_$arch.ipk
if [ -e $pkgnames ]; then
- echo "Found $pkgnames"
+ oenote "Found $pkgnames"
cp $pkgnames ${SDK_OUTPUT}/${prefix}/ipk/
orig_pkg=`ipkg-list-fields $pkgnames | grep OE: | cut -d ' ' -f2`
- pkg_subdir=$arch${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
+ pkg_subdir_postfix=${TARGET_VENDOR}${@['-' + bb.data.getVar('TARGET_OS', d, 1), ''][bb.data.getVar('TARGET_OS', d, 1) == ('' or 'custom')]}
+ for aarch in $revipkgarchs; do
+ if [ -e "${STAGING_DIR}/pkgdata/${aarch}${pkg_subdir_postfix}/${orig_pkg}" ]; then
+ pkg_subdir="${aarch}${pkg_subdir_postfix}"
+ break
+ fi
+ done
+ oenote "Original package in ${pkg_subdir}"
mkdir -p ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/runtime
cp ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg ${SDK_OUTPUT}/${prefix}/pkgdata/$pkg_subdir/
subpkgs=`cat ${STAGING_DIR}/pkgdata/$pkg_subdir/$orig_pkg | grep PACKAGES: | cut -b 10-`