aboutsummaryrefslogtreecommitdiffstats
path: root/packages/maemo/libosso-help
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/maemo/libosso-help
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/maemo/libosso-help')
-rw-r--r--packages/maemo/libosso-help/.mtn2git_empty0
-rw-r--r--packages/maemo/libosso-help/help-header-pp.patch18
-rw-r--r--packages/maemo/libosso-help/no-Werror.patch33
3 files changed, 51 insertions, 0 deletions
diff --git a/packages/maemo/libosso-help/.mtn2git_empty b/packages/maemo/libosso-help/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/maemo/libosso-help/.mtn2git_empty
diff --git a/packages/maemo/libosso-help/help-header-pp.patch b/packages/maemo/libosso-help/help-header-pp.patch
index e69de29bb2..d0769911d2 100644
--- a/packages/maemo/libosso-help/help-header-pp.patch
+++ b/packages/maemo/libosso-help/help-header-pp.patch
@@ -0,0 +1,18 @@
+--- helplib/osso-helplib.h.old 2005-06-09 17:47:50.000000000 +0200
++++ helplib/osso-helplib.h 2005-06-09 17:48:03.000000000 +0200
+@@ -76,7 +76,7 @@
+ const gchar *help_id,
+ guint flags );
+
+-// Helper macros (deprecated)
++/* Helper macros (deprecated) */
+ #define ossohelp_dialog( osso, help_id ) \
+ ossohelp_show( (osso), (help_id), OSSO_HELP_SHOW_DIALOG )
+ #define ossohelp_exists( help_id ) \
+@@ -86,5 +86,5 @@
+ }
+ #endif
+
+-#endif // OSSO_HELPLIB_H
++#endif /* OSSO_HELPLIB_H */
+
diff --git a/packages/maemo/libosso-help/no-Werror.patch b/packages/maemo/libosso-help/no-Werror.patch
index e69de29bb2..b50d50fc51 100644
--- a/packages/maemo/libosso-help/no-Werror.patch
+++ b/packages/maemo/libosso-help/no-Werror.patch
@@ -0,0 +1,33 @@
+--- configure.ac.old 2005-06-09 17:27:01.000000000 +0200
++++ configure.ac 2005-06-09 17:27:20.000000000 +0200
+@@ -29,7 +29,7 @@
+ # Set compilation flags
+
+ CFLAGS="$CFLAGS -Wall -Wmissing-prototypes -Wmissing-declarations \
+- -pedantic-errors -Wcast-align -std=c99 -Werror"
++ -Wcast-align -std=c99"
+
+ # So says the Coding Spec (doesn't -Wall cover these..?!?)
+ CFLAGS+="-Wunreachable-code -Wcast-align"
+--- helplib/Makefile.am.old 2005-06-09 17:33:08.000000000 +0200
++++ helplib/Makefile.am 2005-06-09 17:33:47.000000000 +0200
+@@ -21,7 +21,7 @@
+
+ # Disable this only if system libs give warnings:
+ #
+-libossohelp_la_CFLAGS+=-pedantic-errors -Werror
++#libossohelp_la_CFLAGS+=-pedantic-errors
+
+ libossohelp_la_includedir = $(includedir)
+ libossohelp_la_include_HEADERS = osso-helplib.h
+--- helptest/Makefile.am.old 2005-06-09 17:34:44.000000000 +0200
++++ helptest/Makefile.am 2005-06-09 17:34:55.000000000 +0200
+@@ -23,7 +23,7 @@
+
+ # Disable this only if system libs give warnings:
+ #
+-helptest_CFLAGS+=-pedantic-errors -Werror
++#helptest_CFLAGS+=-pedantic-errors
+
+ helptest_SOURCES = \
+ helptest.c