aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lirc
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-22 12:53:55 +0000
commit4f857db335de6935077d4866c51dd9d6851fed1d (patch)
tree1c923be071d1a56bd79f467fd75ac77959a493a3 /packages/lirc
parentb32403d57d7e0473dd336e76f95c7b26f113cf26 (diff)
downloadopenembedded-4f857db335de6935077d4866c51dd9d6851fed1d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/21 17:35:27-06:00 ti.com!kergoth Kill the ipkg paths patch, since its busted. 2005/02/21 17:33:13-06:00 ti.com!kergoth Fix sbindir in native.bbclass and cross.bbclass. Thanks to Jordan Crouse for reporting. 2005/02/21 17:13:19-06:00 ti.com!kergoth Add the paths patch to ipkg which fixes it to no longer hardcode the '/usr/lib/ipkg' path, which I forgot to check in from the previous commit. 2005/02/21 17:09:46-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/user/oe/openembedded 2005/02/21 17:09:03-06:00 ti.com!kergoth Run a sed script against our packages to fix some hardcoded target path references. As always when I do things like this, if packages you maintain were touched by this, please do a sanity check to ensure the sed script didn't run wild. 2005/02/21 15:49:47-06:00 ti.com!kergoth Use a HOTPLUG variable to manage which hotplug you prefer, to ensure that hotplug is still included in task-bootstrap even if you dont set DISTRO. BKrev: 421b2b63X5eoMcSrC7pVcptXK-iFKg
Diffstat (limited to 'packages/lirc')
-rw-r--r--packages/lirc/lirc-modules_0.6.6.bb37
-rw-r--r--packages/lirc/lirc_0.6.6+cvs20040918.bb51
-rw-r--r--packages/lirc/lirc_0.7.0.bb40
3 files changed, 128 insertions, 0 deletions
diff --git a/packages/lirc/lirc-modules_0.6.6.bb b/packages/lirc/lirc-modules_0.6.6.bb
index e69de29bb2..6235156148 100644
--- a/packages/lirc/lirc-modules_0.6.6.bb
+++ b/packages/lirc/lirc-modules_0.6.6.bb
@@ -0,0 +1,37 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "linux-${KERNEL_VERSION}"
+DEPENDS = "virtual/kernel"
+PR = "r1"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz"
+S = "${WORKDIR}/lirc-${PV}"
+
+inherit autotools module-base
+
+EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_beagle = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+
+export TOPDIR = "${STAGING_KERNEL_DIR}"
+
+do_compile() {
+ cd drivers && oe_runmake CC="${KERNEL_CC}" LD="${KERNEL_LD}"
+}
+
+do_install() {
+ install -d ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/char
+ install -m 0644 drivers/lirc_sir/lirc_sir.o ${D}/${base_libdir}/modules/${KERNEL_VERSION}/kernel/drivers/char/lirc_sir.o
+}
+
+pkg_postinst() {
+#!/bin/sh
+ mknod /dev/lirc c 61 0
+ if [ -n $D ]; then exit 1; fi
+}
+
+FILES_${PN}="/lib/modules"
diff --git a/packages/lirc/lirc_0.6.6+cvs20040918.bb b/packages/lirc/lirc_0.6.6+cvs20040918.bb
index e69de29bb2..9949c0a4dd 100644
--- a/packages/lirc/lirc_0.6.6+cvs20040918.bb
+++ b/packages/lirc/lirc_0.6.6+cvs20040918.bb
@@ -0,0 +1,51 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+RDEPENDS = "kernel lirc-modules-${PV}"
+DEPENDS = "virtual/kernel"
+PR = "r7"
+
+S = "${WORKDIR}/lirc"
+SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/lirc;module=lirc;date=20040918;method=pserver \
+ file://split-hauppauge.patch;patch=1 \
+ file://lircd.init file://lircmd.init"
+
+inherit autotools module-base update-rc.d
+
+INITSCRIPT_NAME = "lirc"
+INITSCRIPT_PARAMS = "defaults 20"
+
+EXTRA_OECONF_epia = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=serial"
+EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_beagle = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+
+EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'
+
+do_stage() {
+ oe_libinstall -so -C tools liblirc_client ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/lirc/
+ install -m 0644 tools/lirc_client.h ${STAGING_INCDIR}/lirc/
+}
+
+do_install() {
+ install -d ${D}/${bindir}
+
+ install -m 755 daemons/irrecord ${D}/${bindir}/irrecord
+ install -m 755 daemons/lircd ${D}/${bindir}/lircd
+
+ oe_libinstall -so -C tools liblirc_client ${D}${libdir}/
+ install -d ${D}${includedir}
+ install -m 0644 tools/lirc_client.h ${D}${includedir}/
+
+ install -d ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/lircd.init ${D}/${sysconfdir}/init.d/lircd
+
+ install -d ${D}${datadir}/lirc/
+ cp -a remotes ${D}${datadir}/lirc/
+ find ${D}${datadir}/lirc -name CVS -o -name '*~*' | xargs rm -rf
+}
+
diff --git a/packages/lirc/lirc_0.7.0.bb b/packages/lirc/lirc_0.7.0.bb
index e69de29bb2..eb062770bc 100644
--- a/packages/lirc/lirc_0.7.0.bb
+++ b/packages/lirc/lirc_0.7.0.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "LIRC is a package that allows you to decode and send infra-red signals of many commonly used remote controls."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+DEPENDS = "virtual/kernel"
+PR = "r5"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/lirc/lirc-${PV}.tar.gz \
+ file://split-hauppauge.patch;patch=1 \
+ file://lircd.init file://lircmd.init"
+S = "${WORKDIR}/lirc-${PV}"
+
+inherit autotools module-base update-rc.d
+
+INITSCRIPT_NAME = "lirc"
+INITSCRIPT_PARAMS = "defaults 20"
+
+EXTRA_OECONF_epia = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=serial"
+EXTRA_OECONF_collie = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_h3600 = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_beagle = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+EXTRA_OECONF_simpad = "--with-kerneldir=${STAGING_KERNEL_DIR} --with-driver=sa1100 --without-x"
+
+EXTRA_OEMAKE = 'SUBDIRS="daemons tools"'
+
+do_stage() {
+ oe_libinstall -so -C tools liblirc_client ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/lirc/
+ install -m 0644 tools/lirc_client.h ${STAGING_INCDIR}/lirc/
+}
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}/init.d
+ install ${WORKDIR}/lircd.init ${D}/${sysconfdir}/init.d/lircd
+
+ install -d ${D}${datadir}/lirc/
+ cp -a ${S}/remotes ${D}${datadir}/lirc/
+}
+