aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2005-09-16 12:59:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-16 12:59:18 +0000
commitf5fb2e35fa9b4877beeb3aa81f43e47cd0582405 (patch)
treeb25fd53ce233d70635cfc359ad9a3cacc3756ccf /packages/linux
parent7f81aa50dbf7c580d55da5dfda6873929f3ec288 (diff)
downloadopenembedded-f5fb2e35fa9b4877beeb3aa81f43e47cd0582405.tar.gz
handhelds-pxa-2.6: add a bb for 2.6.12-hh3
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb25
1 files changed, 25 insertions, 0 deletions
diff --git a/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb b/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb
new file mode 100644
index 0000000000..1ecc553cf9
--- /dev/null
+++ b/packages/linux/handhelds-pxa-2.6_2.6.12-hh3.bb
@@ -0,0 +1,25 @@
+SECTION = "kernel"
+DESCRIPTION = "handhelds.org Linux kernel for PXA based devices."
+MAINTAINER = "Greg Gilbert <greg@treke.net>"
+LICENSE = "GPL"
+#
+COMPATIBLE_HOST = "arm.*-linux"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/handhelds-pxa-${PV}"
+
+SRC_URI = "${HANDHELDS_CVS};module=linux/kernel26;tag=${@'K' + bb.data.getVar('PV',d,1).replace('.', '-')}"
+
+S = "${WORKDIR}/kernel26"
+
+inherit kernel
+
+K_MAJOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[0]}"
+K_MINOR = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[1]}"
+K_MICRO = "${@bb.data.getVar('PV',d,1).split('-')[0].split('.')[2]}"
+HHV = "${@bb.data.getVar('PV',d,1).split('-')[1].split('hh')[-1]}"
+
+KERNEL_PRIORITY = "${@'%d' % (int(bb.data.getVar('K_MAJOR',d,1)) * 100000000 + int(bb.data.getVar('K_MINOR',d,1)) * 1000000 + int(bb.data.getVar('K_MICRO',d,1)) * 10000 + float(bb.data.getVar('HHV',d,1)))}"
+do_configure() {
+ install -m 0644 arch/arm/configs/ipaqpxa_defconfig .config
+ yes '' | oe_runmake oldconfig
+}