aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorHenning Heinold <heinold@inf.fu-berlin.de>2008-10-04 21:07:45 +0000
committerHenning Heinold <heinold@inf.fu-berlin.de>2008-10-04 21:07:45 +0000
commit282d57299747bd465f8306dd259b7f8efbecda37 (patch)
treecb18728b4a61d5f0466accfe8e3f7cf462c283de /packages/linux
parent8cbb2a02a7f96ba8629e3ccec5dede40ef7fbd81 (diff)
downloadopenembedded-282d57299747bd465f8306dd259b7f8efbecda37.tar.gz
linux-2.6.24: fix compile for archs that do not support __udivdi3()
* add time.h.patch from kernel ml * bump PR
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-2.6.24/time.h.patch25
-rw-r--r--packages/linux/linux_2.6.24.bb3
2 files changed, 27 insertions, 1 deletions
diff --git a/packages/linux/linux-2.6.24/time.h.patch b/packages/linux/linux-2.6.24/time.h.patch
new file mode 100644
index 0000000000..fd22f3a01d
--- /dev/null
+++ b/packages/linux/linux-2.6.24/time.h.patch
@@ -0,0 +1,25 @@
+....since some architectures don't support __udivdi3() (and
+ we don't want to use that, anyway).
+
+ Signed-off-by: Segher Boessenkool
+ ---
+ include/linux/time.h | 4 ++++
+ 1 files changed, 4 insertions(+), 0 deletions(-)
+
+
+Index: linux-2.6.24/include/linux/time.h
+===================================================================
+--- linux-2.6.24.orig/include/linux/time.h 2008-06-23 11:17:09.021841180 +0200
++++ linux-2.6.24/include/linux/time.h 2008-06-23 11:18:34.445167140 +0200
+@@ -173,6 +173,11 @@
+ {
+ ns += a->tv_nsec;
+ while(unlikely(ns >= NSEC_PER_SEC)) {
++ /* The following asm() prevents the compiler from
++ * optimising this loop into a modulo operation.
++ */
++ asm("" : "+r"(ns));
++
+ ns -= NSEC_PER_SEC;
+ a->tv_sec++;
+ }
diff --git a/packages/linux/linux_2.6.24.bb b/packages/linux/linux_2.6.24.bb
index 7fd2f457e4..de12e4c345 100644
--- a/packages/linux/linux_2.6.24.bb
+++ b/packages/linux/linux_2.6.24.bb
@@ -10,10 +10,11 @@ DEFAULT_PREFERENCE_at32stk1000 = "1"
DEFAULT_PREFERENCE_ts72xx = "1"
DEFAULT_PREFERENCE_cs-e9302 = "1"
-PR = "r14"
+PR = "r15"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.24.tar.bz2 \
http://kamikaze.waninkoko.info/patches/2.6.24/kamikaze1/broken-out/squashfs-lzma-2.6.24.patch;patch=1 \
+ file://time.h.patch;patch=1 \
file://defconfig"
# Moved away temporarely until committed properly (work in progress).