aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-01-02 22:01:21 +0000
committerPhilip Balister <philip@balister.org>2007-01-02 22:01:21 +0000
commit0f8fb7dd8a24cf4d058408f02a645fc38c7cb229 (patch)
tree3a35b71d580416186c29bacaf1c2baa952966ee5 /packages/linux
parent26923fcad450090e65e0fca74a0532fbea3ae458 (diff)
downloadopenembedded-0f8fb7dd8a24cf4d058408f02a645fc38c7cb229.tar.gz
linux-omap1-2.6.19-omap1 : Add patch to fix kernel oops starting ALSA.
Diffstat (limited to 'packages/linux')
-rw-r--r--packages/linux/linux-omap1-2.6.19-omap1/i2c-fix.patch56
-rw-r--r--packages/linux/linux-omap1_2.6.19-omap1.bb3
2 files changed, 57 insertions, 2 deletions
diff --git a/packages/linux/linux-omap1-2.6.19-omap1/i2c-fix.patch b/packages/linux/linux-omap1-2.6.19-omap1/i2c-fix.patch
new file mode 100644
index 0000000000..3b35ce23a2
--- /dev/null
+++ b/packages/linux/linux-omap1-2.6.19-omap1/i2c-fix.patch
@@ -0,0 +1,56 @@
+Hack to add I2C zero length transfers and SMBus quick mode
+necessary for AIC23 sound again.
+
+Signed-off-by: Dirk Behme <dirk.behme_at_gmail.com>
+
+
+-------------- next part --------------
+Index: linux-osk/drivers/i2c/busses/i2c-omap.c
+===================================================================
+--- linux-osk.orig/drivers/i2c/busses/i2c-omap.c
++++ linux-osk/drivers/i2c/busses/i2c-omap.c
+@@ -285,20 +285,29 @@ static int omap_i2c_xfer_msg(struct i2c_
+ struct i2c_msg *msg, int stop)
+ {
+ struct omap_i2c_dev *dev = i2c_get_adapdata(adap);
++ u8 zero_byte = 0;
+ int r;
+ u16 w;
+
+ dev_dbg(dev->dev, "addr: 0x%04x, len: %d, flags: 0x%x, stop: %d\n",
+ msg->addr, msg->len, msg->flags, stop);
+
+- if (msg->len == 0)
+- return -EINVAL;
+-
+ omap_i2c_write_reg(dev, OMAP_I2C_SA_REG, msg->addr);
+
+- /* REVISIT: Could the STB bit of I2C_CON be used with probing? */
+- dev->buf = msg->buf;
+- dev->buf_len = msg->len;
++ /* Sigh, seems we can't do zero length transactions. Thus, we
++ * can't probe for devices w/o actually sending/receiving at least
++ * a single byte. So we'll set count to 1 for the zero length
++ * transaction case and hope we don't cause grief for some
++ * arbitrary device due to random byte write/read during
++ * probes.
++ */
++ if (msg->len == 0) {
++ dev->buf = &zero_byte;
++ dev->buf_len = 1;
++ } else {
++ dev->buf = msg->buf;
++ dev->buf_len = msg->len;
++ }
+
+ omap_i2c_write_reg(dev, OMAP_I2C_CNT_REG, dev->buf_len);
+
+@@ -383,7 +392,7 @@ out:
+ static u32
+ omap_i2c_func(struct i2c_adapter *adap)
+ {
+- return I2C_FUNC_I2C | (I2C_FUNC_SMBUS_EMUL & ~I2C_FUNC_SMBUS_QUICK);
++ return I2C_FUNC_I2C | I2C_FUNC_SMBUS_EMUL;
+ }
+
+ static inline void
diff --git a/packages/linux/linux-omap1_2.6.19-omap1.bb b/packages/linux/linux-omap1_2.6.19-omap1.bb
index ca43d567c0..cfe0723770 100644
--- a/packages/linux/linux-omap1_2.6.19-omap1.bb
+++ b/packages/linux/linux-omap1_2.6.19-omap1.bb
@@ -1,10 +1,9 @@
require linux-omap1.inc
-DEFAULT_PREFERENCE = "-1"
-
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-2.6.19.tar.bz2 \
http://www.muru.com/linux/omap/patches/patch-2.6.19-omap1.bz2;patch=1 \
file://another-ide-cs-ids.patch;patch=1 \
+ file://i2c-fix.patch;patch=1 \
file://defconfig \
file://defconfig.eabi"