aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-z_2.6.20.bb
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-02-16 14:10:25 +0000
committerHolger Freyther <zecke@selfish.org>2007-02-16 14:10:25 +0000
commit1e37747e5b6b1edf55ddd01569752866f8e679dd (patch)
treecdf676f01f4cbe8eaee8aa767957efddf99051f0 /packages/linux/linux-z_2.6.20.bb
parent4036cccc94373ca4048c23780915814fd3ae15ff (diff)
downloadopenembedded-1e37747e5b6b1edf55ddd01569752866f8e679dd.tar.gz
Add the DNARD/Shark machine configuration and kernel
The DNARD/Shark was the Network Computer constructed by DEC with spare StrongARM processors. Here we use them as music basestations.
Diffstat (limited to 'packages/linux/linux-z_2.6.20.bb')
-rw-r--r--packages/linux/linux-z_2.6.20.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/linux/linux-z_2.6.20.bb b/packages/linux/linux-z_2.6.20.bb
new file mode 100644
index 0000000000..b707a2649b
--- /dev/null
+++ b/packages/linux/linux-z_2.6.20.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "2.6 Linux Development Kernel for the DNARD/Shark, SIMpad."
+SECTION = "kernel"
+LICENSE = "GPL"
+
+inherit kernel
+
+S = "${WORKDIR}/git"
+SRC_URI = "git://www.openembedded.org/~zecke/git/linux/linux-2.6/.git;protocol=http \
+ file://defconfig"
+
+
+RPROVIDES_kernel-image += "hostap-modules"
+
+COMPATIBLE_HOST = "(arm).*-linux"
+COMPATIBLE_MACHINE = '(shark)'
+
+
+KERNEL_IMAGETYPE = "zImage"
+
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconfig ${S}/.config
+}