aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-sequoia_2.6.21.bb
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2007-05-28 21:14:45 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2007-05-28 21:14:45 +0000
commit025000e4e9b80cfcea7018c414e4b42afb42542e (patch)
tree718903c00e4a15625b81c9657f8e45a091fea42a /packages/linux/linux-sequoia_2.6.21.bb
parent75d15f094ed56a538991ab55b38e60ee1de2c233 (diff)
downloadopenembedded-025000e4e9b80cfcea7018c414e4b42afb42542e.tar.gz
packages/linux/linux-sequoia-2.6.21 : Add Denx 2.6.21.git kernel for the Sequoia dev board
Diffstat (limited to 'packages/linux/linux-sequoia_2.6.21.bb')
-rw-r--r--packages/linux/linux-sequoia_2.6.21.bb60
1 files changed, 60 insertions, 0 deletions
diff --git a/packages/linux/linux-sequoia_2.6.21.bb b/packages/linux/linux-sequoia_2.6.21.bb
new file mode 100644
index 0000000000..1fa520e914
--- /dev/null
+++ b/packages/linux/linux-sequoia_2.6.21.bb
@@ -0,0 +1,60 @@
+# Copyright (C) 2007, Stelios Koroneos - Digital OPSiS, All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+SECTION = "kernel"
+DESCRIPTION = "Linux kernel for AMCC's Sequoia dev board"
+LICENSE = "GPL"
+PR = "r0"
+#DEPENDS = "u-boot"
+
+COMPATIBLE_MACHINE = "sequoia"
+
+#DENX git kernel
+#Same as in AMCC's sequoia dev kit
+SRC_URI ="git://www.denx.de/git/linux-2.6-denx.git;protocol=git;tag=78157a82fa20719f7e3307307755888e9af2c0e9 \
+ file://sequoia_defconfig "
+
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+export ARCH="ppc"
+
+KERNEL_IMAGETYPE = "zImage.elf"
+
+do_configure() {
+ install -m 644 ${WORKDIR}/sequoia_defconfig ${S}/.config
+ make ARCH=${ARCH} oldconfig
+}
+
+do_stage_append () {
+#need ppc platforms includes + friends in order for external kernel modules to compile as headers a$
+
+ install -d ${STAGING_KERNEL_DIR}/arch/
+ cp -a arch/ppc ${STAGING_KERNEL_DIR}/arch/
+ cp -a arch/powerpc ${STAGING_KERNEL_DIR}/arch/
+
+ install -d ${STAGING_KERNEL_DIR}/include/asm
+ cp -a include/asm-powerpc ${STAGING_KERNEL_DIR}/include/
+ cp -a include/asm-ppc ${STAGING_KERNEL_DIR}/include/
+}
+
+
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE} \
+ ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+#seems like 2.6.21 kernel images have moved (or is this only for the Denx kernel ?)
+#so we need to copy the kernel image where kernel.bbclass expects it to be
+do_install_prepend() {
+ install -m 0644 arch/${ARCH}/boot/images/${KERNEL_IMAGETYPE} \
+ arch/${ARCH}/boot/${KERNEL_IMAGETYPE}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+