aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-navman_2.6.18.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-10-17 17:38:24 +0000
committerKoen Kooi <koen@openembedded.org>2006-10-17 17:38:24 +0000
commiteb910209f4ad155c9ea7844c73fc371a4aa614b1 (patch)
tree7b57626437c6682edbc9877cc59fbc07eff19e04 /packages/linux/linux-navman_2.6.18.bb
parentdf81f9d9d3a0ab36757a6506a88687d4efc2cd87 (diff)
downloadopenembedded-eb910209f4ad155c9ea7844c73fc371a4aa614b1.tar.gz
linux-navman: add kernel for the navman-icn330 machine
* due to some circular deps no uImage is created, but a zImage * the navman's uboot wants kernel headers in order to compile, and the kernel needs mk-image from uboot in order to build the uImage.... Time for an mkimage-native recipe?
Diffstat (limited to 'packages/linux/linux-navman_2.6.18.bb')
-rw-r--r--packages/linux/linux-navman_2.6.18.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/linux/linux-navman_2.6.18.bb b/packages/linux/linux-navman_2.6.18.bb
new file mode 100644
index 0000000000..29d8944a3b
--- /dev/null
+++ b/packages/linux/linux-navman_2.6.18.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
+SECTION = "kernel"
+LICENSE = "GPL"
+
+#DEPENDS = "u-boot"
+
+PR = "r0"
+
+COMPATIBLE_MACHINE = "navman-icn330"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.18.tar.bz2 \
+ http://www.duff.dk/navman/navman-2.6.18.patch;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.18"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+do_configure() {
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" -o "${TARGET_OS}" == "linux-uclibcgnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+