aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-jlime-jornada7xx_2.6.17.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-07-14 13:57:06 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-14 13:57:06 +0000
commitb4fb1a340df59e0db01de9b022ca4697b3d35972 (patch)
tree787b02605bc4e0bb7b2406daa3191b9fd7660526 /packages/linux/linux-jlime-jornada7xx_2.6.17.bb
parent87fce2574a38e51cae0552f07371671ed1bc11df (diff)
downloadopenembedded-b4fb1a340df59e0db01de9b022ca4697b3d35972.tar.gz
Moving linux-jlime-${ARCH}-* -> linux-jlime-${machine}-*:
* Changing from arch->machine due to the addition of 56x support. This requires different kernel but since both 72x and 56x are arm we need to use MACHINE to define instead. conf/local.conf : Changing ARCH -> MACHINE.
Diffstat (limited to 'packages/linux/linux-jlime-jornada7xx_2.6.17.bb')
-rw-r--r--packages/linux/linux-jlime-jornada7xx_2.6.17.bb43
1 files changed, 43 insertions, 0 deletions
diff --git a/packages/linux/linux-jlime-jornada7xx_2.6.17.bb b/packages/linux/linux-jlime-jornada7xx_2.6.17.bb
new file mode 100644
index 0000000000..17c15cba51
--- /dev/null
+++ b/packages/linux/linux-jlime-jornada7xx_2.6.17.bb
@@ -0,0 +1,43 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for Arm based Jornada 7xx"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_HOST = "arm.*-linux"
+COMPATIBLE_MACHINE = "jornada7xx"
+
+SRC_URI = "http://www.kernel.orgm/pub/linux/kernel/v2.6/linux-2.6.17.tar.gz \
+ file://defconf_jlime \
+ file://AsmArm-ArchSa1100-Jornada720.patch;patch=0 \
+ file://Cpu-Sa1110-Jornada720.patch;patch=0 \
+ file://Kconfig-Arch-Jornada720.patch;patch=0 \
+ file://Kconfig-Keyboard-Jornada720.patch;patch=0 \
+ file://Kconfig-Touchscreen-Jornada720.patch;patch=0 \
+ file://Kconfig-Video-Jornada720.patch;patch=0 \
+ file://Mach-Sa1100-Jornada720.patch;patch=0 \
+ file://Makefile-Keyboard-Jornada720.patch;patch=0 \
+ file://Makefile-Touchscreen-Jornada720.patch;patch=0 \
+ file://Makefile-Video-Jornada720.patch;patch=0 \
+ file://Newfile-Epson1356fb.patch;patch=0 \
+ file://Newfile-Jornada720_kbd.patch;patch=0 \
+ file://Newfile-Jornada720_ts.patch;patch=0"
+
+S = "${WORKDIR}/linux-${PV}"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "arm"
+KERNEL_IMAGETYPE = "zImage"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${WORKDIR}/defconf_jlime ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/$(ARCH)/boot/$(KERNEL_IMAGETYPE) $(DEPLOY_DIR)/images/$(KERNEL_IMAGETYPE)
+}