aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-jlime-jornada6xx_2.6.25.bb
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2008-05-08 17:25:44 +0000
committerKristoffer Ericson <kristoffer_e1@hotmail.com>2008-05-08 17:25:44 +0000
commit3252423e764b8ec14995d4fbd41428017f4f2a1b (patch)
tree4ef363bfd4b0725d96be555212cf08002118c4f8 /packages/linux/linux-jlime-jornada6xx_2.6.25.bb
parent32a21b6f84b24bae3c86be043449d1576bb955c7 (diff)
downloadopenembedded-3252423e764b8ec14995d4fbd41428017f4f2a1b.tar.gz
* Addition of jlime jornada6xx kernel (2.6.25) bb file.
This package grabs sources and config from our git repository so no subdir is needed.
Diffstat (limited to 'packages/linux/linux-jlime-jornada6xx_2.6.25.bb')
-rw-r--r--packages/linux/linux-jlime-jornada6xx_2.6.25.bb30
1 files changed, 30 insertions, 0 deletions
diff --git a/packages/linux/linux-jlime-jornada6xx_2.6.25.bb b/packages/linux/linux-jlime-jornada6xx_2.6.25.bb
new file mode 100644
index 0000000000..c55cf1578f
--- /dev/null
+++ b/packages/linux/linux-jlime-jornada6xx_2.6.25.bb
@@ -0,0 +1,30 @@
+SECTION = "kernel"
+DESCRIPTION = "JLime Linux kernel for SuperH based Jornada 6xx"
+LICENSE = "GPL"
+PR = "r0"
+
+SRCREV = "${AUTOREV}"
+
+COMPATIBLE_HOST = "sh.*-linux"
+#COMPATIBLE_MACHINE = "jornada6xx"
+
+SRC_URI = "git://jlime.org/jlime-stable.git;protocol=git;branch=v2.6.25-stable"
+
+S = "${WORKDIR}/git"
+
+inherit kernel
+
+#Lets let 3.4.x handle the compilation of this one
+KERNEL_CCSUFFIX = "-3.4.4"
+
+ARCH = "sh"
+FILES_kernel-image = "/boot/${KERNEL_IMAGETYPE}*"
+
+do_configure_prepend() {
+ install -m 0644 ${S}/config-hp6xx-2.6.25 ${S}/.config
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR}/images/${KERNEL_IMAGETYPE}
+}