aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/linux-ezx-2.6.21/patches
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-09-22 07:41:55 +0000
committerKoen Kooi <koen@openembedded.org>2007-09-22 07:41:55 +0000
commit613ad22e06e94f5fbc8a703b94ee645de0f28d77 (patch)
tree28f76ee1671dd30d245d3e94bfa5ad980e6d8c34 /packages/linux/linux-ezx-2.6.21/patches
parent4fb125dd1d1105e04dd764c5acd3b360e0ce8fd4 (diff)
downloadopenembedded-613ad22e06e94f5fbc8a703b94ee645de0f28d77.tar.gz
linux-ezx: sync a1200 and e6 changes with openezx svn, add more RP patches
Diffstat (limited to 'packages/linux/linux-ezx-2.6.21/patches')
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX50
-rw-r--r--packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch12
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch7
-rw-r--r--packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch12
-rw-r--r--packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch7
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch52
-rw-r--r--packages/linux/linux-ezx-2.6.21/patches/index.html14
-rwxr-xr-xpackages/linux/linux-ezx-2.6.21/patches/series28
8 files changed, 101 insertions, 81 deletions
diff --git a/packages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX b/packages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX
index 7e7e0f2898..c6d90c61b9 100755
--- a/packages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX
+++ b/packages/linux/linux-ezx-2.6.21/patches/Makefile.OpenEZX
@@ -8,12 +8,18 @@
# in your environment.
#
-PHONES = a780 e680 a1200 e2 e6
+PHONES = a780 e680 a1200 e6 e2
CROSS_COMPILE ?= /home/wyrm/ezx/dev/cross/bin/arm-angstrom-linux-gnueabi-
QUILT_PATCHES ?= patches
+LV ?= ezxdev # replace LOCALVERSION string
+J ?= 2 # simultaneous jobs
+SIG ?= 0 # BOOL sign md5sums file
+
DATE = $(shell date +%Y%m%d)
+DEPLOY_SERVER ?= people.openezx.org
+DEPLOY_DIR ?= public_html/images/$(DATE)/
all: $(foreach p, $(PHONES), zImage-$(p) modules-$(p).tar.gz)
@@ -21,8 +27,27 @@ zImages: $(foreach p, $(PHONES), zImage-$(p))
modules: $(foreach p, $(PHONES), modules-$(p).tar.gz)
+config: $(foreach p, $(PHONES), config-$(p))
+
+config-%: $(QUILT_PATCHES)/defconfig-%
+ cp $< .config
+ make ARCH=arm oldconfig
+ cp .config $<
+
+deploy: release
+ ssh $(DEPLOY_SERVER) \
+ mkdir -p $(DEPLOY_DIR)
+ scp ezxrelease-$(DATE).tar $(DEPLOY_SERVER):$(DEPLOY_DIR)
+ ssh $(DEPLOY_SERVER) \
+ cd $(DEPLOY_DIR)\; \
+ tar -xf ezxrelease-$(DATE).tar\; \
+ rm -f ezxrelease-$(DATE).tar
+
release: $(foreach p, $(PHONES), tag-$(p))
- cat md5sums.tmp | gpg --clearsign > md5sums
+ cp md5sums.tmp md5sums
+ test "$(SIG)" = "1" && \
+ cat md5sums.tmp | gpg --clearsign > md5sums \
+ ; echo
tar -rf ezxrelease.tar md5sums
rm -f md5sums.tmp md5sums
mv ezxrelease.tar ezxrelease-$(DATE).tar
@@ -30,22 +55,23 @@ release: $(foreach p, $(PHONES), tag-$(p))
tag-%: zImage-% modules-%.tar.gz
p=$(patsubst tag-%,%,$@) && \
tag=$(shell cat include/config/kernel.release)-$(DATE) && \
- cp zImage-$$p zImage-$$tag-$$p && \
- cp modules-$$p.tar.gz modules-$$tag-$$p.tar.gz && \
+ mv zImage-$$p zImage-$$tag-$$p && \
+ mv modules-$$p.tar.gz modules-$$tag-$$p.tar.gz && \
tar -rf ezxrelease.tar zImage-$$tag-$$p modules-$$tag-$$p.tar.gz && \
md5sum zImage-$$tag-$$p modules-$$tag-$$p.tar.gz >> md5sums.tmp && \
rm -f zImage-$$tag-$$p modules-$$tag-$$p.tar.gz
zImage-%: $(QUILT_PATCHES)/defconfig-%
- cp $< ./.config
- make ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) zImage
+ cat $< | sed 's/LOCALVERSION=".*"$$/LOCALVERSION="-$(LV)"/' > .config
+ make -j$(J) ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) zImage
mv arch/arm/boot/zImage $@
modules-%.tar.gz: $(QUILT_PATCHES)/defconfig-%
- cp $< ./.config
+ cat $< | sed 's/LOCALVERSION=".*"$$/LOCALVERSION="-$(LV)"/' > .config
-find . -name "*.ko" -print0 | xargs -r0 rm
- mkdir /tmp/$@
- make ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) \
- INSTALL_MOD_PATH=/tmp/$@ modules modules_install
- tar -C /tmp/$@ -czf $@ .
- rm -rf /tmp/$@
+ mkdir -p Makefile.OpenEZX-tmp/$@
+ make -j$(J) ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) modules
+ make -j1 ARCH=arm CROSS_COMPILE=$(CROSS_COMPILE) \
+ INSTALL_MOD_PATH=Makefile.OpenEZX-tmp/$@ modules_install
+ tar -C Makefile.OpenEZX-tmp/$@ -czf $@ .
+ rm -rf Makefile.OpenEZX-tmp/
diff --git a/packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch b/packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch
index 577aa66303..e6146058a0 100644
--- a/packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch
+++ b/packages/linux/linux-ezx-2.6.21/patches/a1200-eoc.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c 2007-09-07 22:15:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-09 13:29:56.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:38:52.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:48:23.000000000 -0300
@@ -25,6 +25,7 @@
#include <asm/arch/mmc.h>
@@ -10,8 +10,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
extern void ezx_lcd_power(int, struct fb_var_screeninfo *);
extern void ezx_backlight_power(int);
-@@ -227,11 +228,69 @@
- .resource = pcap_ts_resources,
+@@ -203,8 +204,65 @@
+ },
};
+
@@ -72,11 +72,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
+
static struct platform_device *devices[] __initdata = {
&a1200_pcap_device,
- &pcap_ts_device,
+ &a1200_eoc_device,
};
-+
static void __init a1200_init(void)
- {
- set_pxa_fb_info(&a1200_fb_info);
diff --git a/packages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch b/packages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch
index a8c8f2ee29..2327257507 100755
--- a/packages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch
+++ b/packages/linux/linux-ezx-2.6.21/patches/a1200-ts.patch
@@ -1,8 +1,8 @@
Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c 2007-09-07 11:54:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-07 11:55:10.000000000 -0300
-@@ -203,8 +203,33 @@
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:50:31.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c 2007-09-21 21:51:06.000000000 -0300
+@@ -260,9 +260,34 @@
},
};
@@ -32,6 +32,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-a1200.c
+
static struct platform_device *devices[] __initdata = {
&a1200_pcap_device,
+ &a1200_eoc_device,
+ &pcap_ts_device,
};
diff --git a/packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch b/packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch
index 79c60c8ca2..f6e152c735 100644
--- a/packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch
+++ b/packages/linux/linux-ezx-2.6.21/patches/e6-eoc.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c 2007-09-07 22:15:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c 2007-09-09 13:29:56.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c 2007-09-21 21:38:52.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c 2007-09-21 21:49:42.000000000 -0300
@@ -25,6 +25,7 @@
#include <asm/arch/mmc.h>
@@ -10,8 +10,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
extern void ezx_lcd_power(int, struct fb_var_screeninfo *);
extern void ezx_backlight_power(int);
-@@ -227,11 +228,69 @@
- .resource = pcap_ts_resources,
+@@ -203,8 +204,65 @@
+ },
};
+
@@ -72,11 +72,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
+
static struct platform_device *devices[] __initdata = {
&e6_pcap_device,
- &pcap_ts_device,
+ &e6_eoc_device,
};
-+
static void __init e6_init(void)
- {
- set_pxa_fb_info(&e6_fb_info);
diff --git a/packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch b/packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch
index 6472f77886..a39b782300 100644
--- a/packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch
+++ b/packages/linux/linux-ezx-2.6.21/patches/e6-ts.patch
@@ -1,8 +1,8 @@
Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c 2007-09-07 11:54:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c 2007-09-07 11:55:10.000000000 -0300
-@@ -203,8 +203,33 @@
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx-e6.c 2007-09-21 21:50:31.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c 2007-09-21 21:51:40.000000000 -0300
+@@ -260,9 +260,34 @@
},
};
@@ -32,6 +32,7 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx-e6.c
+
static struct platform_device *devices[] __initdata = {
&e6_pcap_device,
+ &e6_eoc_device,
+ &pcap_ts_device,
};
diff --git a/packages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch b/packages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch
index ff3413f062..05748e681c 100755
--- a/packages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch
+++ b/packages/linux/linux-ezx-2.6.21/patches/ezx-pm.patch
@@ -1,7 +1,7 @@
Index: linux-2.6.21/arch/arm/mach-pxa/pxa27x.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/pxa27x.c 2007-06-28 19:44:28.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/pxa27x.c 2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/pxa27x.c 2007-09-21 23:57:40.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/pxa27x.c 2007-09-21 23:57:49.000000000 -0300
@@ -22,6 +22,10 @@
#include <asm/arch/pxa-regs.h>
#include <asm/arch/ohci.h>
@@ -29,8 +29,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/pxa27x.c
}
Index: linux-2.6.21/arch/arm/mach-pxa/pm.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/pm.c 2007-06-28 19:44:28.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/pm.c 2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/pm.c 2007-09-21 23:57:40.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/pm.c 2007-09-21 23:57:49.000000000 -0300
@@ -24,6 +24,10 @@
#include <asm/arch/lubbock.h>
#include <asm/mach/time.h>
@@ -58,8 +58,8 @@ Index: linux-2.6.21/arch/arm/mach-pxa/pm.c
RESTORE(GPDR0); RESTORE(GPDR1); RESTORE(GPDR2);
Index: linux-2.6.21/arch/arm/mach-pxa/ezx.c
===================================================================
---- linux-2.6.21.orig/arch/arm/mach-pxa/ezx.c 2007-06-28 19:44:52.000000000 -0300
-+++ linux-2.6.21/arch/arm/mach-pxa/ezx.c 2007-06-28 19:44:58.000000000 -0300
+--- linux-2.6.21.orig/arch/arm/mach-pxa/ezx.c 2007-09-21 23:57:48.000000000 -0300
++++ linux-2.6.21/arch/arm/mach-pxa/ezx.c 2007-09-22 00:07:34.000000000 -0300
@@ -19,6 +19,7 @@
#include <asm/arch/pxa-regs.h>
#include <asm/arch/ohci.h>
@@ -68,49 +68,33 @@ Index: linux-2.6.21/arch/arm/mach-pxa/ezx.c
#include "generic.h"
-@@ -122,8 +123,69 @@
+@@ -122,8 +123,53 @@
&ezxbp_device,
};
+/* PM */
+extern int bp_handshake_passed(void);
+
-+#define POWER_OFF_TIMEOUT (2*60*HZ)
-+
+static void ezx_reboot_poweroff(char mode)
+{
-+#ifdef CONFIG_EZX_BP
-+ unsigned long start = jiffies;
-+
-+ printk("Waiting for BP to turn off. This can take some time...\n");
+ *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = NO_FLAG;
+ cpu_proc_fin();
+
-+ do {
-+ /*
-+ * Turn off gracefully. Wait BP turn off first, and then
-+ * properly turn off.
-+ */
-+ if (pxa_gpio_get_value(GPIO_BB_WDI) == 0) {
-+ *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = WDI_FLAG;
++#ifdef CONFIG_EZX_BP
++ if (pxa_gpio_get_value(GPIO_BB_WDI) == 0) {
++ *(unsigned long *)(phys_to_virt(BPSIG_ADDR)) = WDI_FLAG;
+
-+ /* reset BP */
-+ pxa_gpio_set_value(GPIO_BB_RESET, 0);
-+ mdelay(1);
-+ pxa_gpio_set_value(GPIO_BB_RESET, 1);
++ /* reset BP */
++ pxa_gpio_set_value(GPIO_BB_RESET, 0);
++ mdelay(1);
++ pxa_gpio_set_value(GPIO_BB_RESET, 1);
+
-+ if (mode == 'z')
-+ arch_reset('h');
-+ break;
-+ }
-+ /* Just turn it off! */
-+ if (!bp_handshake_passed() || !pxa_gpio_get_value(GPIO_BB_WDI2)
-+ || (jiffies - start) >= POWER_OFF_TIMEOUT) {
-+ break;
++ if (mode == 'z') {
++ arch_reset('h');
++ while(1);
+ }
-+ } while(1);
++ }
+#endif
-+
+ if (mode == 'z')
+ /* Panic! Ask PCAP to turn both processors off */
+ pxa_gpio_set_value(GPIO_WDI_AP, 0);
diff --git a/packages/linux/linux-ezx-2.6.21/patches/index.html b/packages/linux/linux-ezx-2.6.21/patches/index.html
index 4d57380e0c..bbbb40d590 100644
--- a/packages/linux/linux-ezx-2.6.21/patches/index.html
+++ b/packages/linux/linux-ezx-2.6.21/patches/index.html
@@ -1,9 +1,10 @@
-<html><head><title>Revision 2047: /trunk/src/kernel-2.6/patches</title></head>
+<html><head><title>Revision 2059: /trunk/src/kernel-2.6/patches</title></head>
<body>
- <h2>Revision 2047: /trunk/src/kernel-2.6/patches</h2>
+ <h2>Revision 2059: /trunk/src/kernel-2.6/patches</h2>
<ul>
<li><a href="../">..</a></li>
<li><a href="Makefile.OpenEZX">Makefile.OpenEZX</a></li>
+ <li><a href="a1200-eoc.patch">a1200-eoc.patch</a></li>
<li><a href="a1200-mci.patch">a1200-mci.patch</a></li>
<li><a href="a1200-pcap.patch">a1200-pcap.patch</a></li>
<li><a href="a1200-ts.patch">a1200-ts.patch</a></li>
@@ -15,6 +16,7 @@
<li><a href="a780-pcap.patch">a780-pcap.patch</a></li>
<li><a href="a780-ts.patch">a780-ts.patch</a></li>
<li><a href="a780-vibrator.patch">a780-vibrator.patch</a></li>
+ <li><a href="asoc-fix-loopback.patch">asoc-fix-loopback.patch</a></li>
<li><a href="asoc-pxa-ssp.patch">asoc-pxa-ssp.patch</a></li>
<li><a href="defconfig-a1200">defconfig-a1200</a></li>
<li><a href="defconfig-a780">defconfig-a780</a></li>
@@ -22,6 +24,10 @@
<li><a href="defconfig-e6">defconfig-e6</a></li>
<li><a href="defconfig-e680">defconfig-e680</a></li>
<li><a href="dmesg-a780.log">dmesg-a780.log</a></li>
+ <li><a href="e6-eoc.patch">e6-eoc.patch</a></li>
+ <li><a href="e6-mci.patch">e6-mci.patch</a></li>
+ <li><a href="e6-pcap.patch">e6-pcap.patch</a></li>
+ <li><a href="e6-ts.patch">e6-ts.patch</a></li>
<li><a href="e680-emu.patch">e680-emu.patch</a></li>
<li><a href="e680-kbd.patch">e680-kbd.patch</a></li>
<li><a href="e680-leds.patch">e680-leds.patch</a></li>
@@ -35,10 +41,13 @@
<li><a href="ezx-core.patch">ezx-core.patch</a></li>
<li><a href="ezx-emu.patch">ezx-emu.patch</a></li>
<li><a href="ezx-enable-stuart.patch">ezx-enable-stuart.patch</a></li>
+ <li><a href="ezx-eoc.patch">ezx-eoc.patch</a></li>
<li><a href="ezx-mtd-map.patch">ezx-mtd-map.patch</a></li>
<li><a href="ezx-pcap.patch">ezx-pcap.patch</a></li>
<li><a href="ezx-pm.patch">ezx-pm.patch</a></li>
<li><a href="ezx-serial-bug-workaround.patch">ezx-serial-bug-workaround.patch</a></li>
+ <li><a href="i2c-core-fix-a1200.patch">i2c-core-fix-a1200.patch</a></li>
+ <li><a href="mtdfix.patch">mtdfix.patch</a></li>
<li><a href="mux-fix-init-errorpath.patch">mux-fix-init-errorpath.patch</a></li>
<li><a href="mux-fix-makefile.patch">mux-fix-makefile.patch</a></li>
<li><a href="mux-fix-tty-driver.patch">mux-fix-tty-driver.patch</a></li>
@@ -53,6 +62,7 @@
<li><a href="patch-2.6.21.4">patch-2.6.21.4</a></li>
<li><a href="pcap-ts.patch">pcap-ts.patch</a></li>
<li><a href="pxa-kbd.patch">pxa-kbd.patch</a></li>
+ <li><a href="pxa27x-udc-fix-a1200.patch">pxa27x-udc-fix-a1200.patch</a></li>
<li><a href="pxa27x-udc-support.2.patch">pxa27x-udc-support.2.patch</a></li>
<li><a href="series">series</a></li>
</ul>
diff --git a/packages/linux/linux-ezx-2.6.21/patches/series b/packages/linux/linux-ezx-2.6.21/patches/series
index ecdc30b5fe..aa95fcbc78 100755
--- a/packages/linux/linux-ezx-2.6.21/patches/series
+++ b/packages/linux/linux-ezx-2.6.21/patches/series
@@ -1,4 +1,5 @@
patch-2.6.21.4
+mtdfix.patch
ezx-core.patch
# ezx-core TODO: should be ezx-common
@@ -25,10 +26,12 @@ ezx-pcap.patch
a780-pcap.patch
e680-pcap.patch
a1200-pcap.patch
+e6-pcap.patch
a780-mci.patch
e680-mci.patch
a1200-mci.patch
+e6-mci.patch
pxa27x-udc-support.2.patch
@@ -36,23 +39,18 @@ ezx-emu.patch
# ezx-emu TODO:
# userspace interface for controling emu
# read adc to find which accessory is plugged
-
a780-emu.patch
e680-emu.patch
+ezx-eoc.patch
+a1200-eoc.patch
+e6-eoc.patch
+
ezx-mtd-map.patch
-# ezx-mtd-map TODO:
-# at least the original partition should go on the ezx-phone.c file
ezx-serial-bug-workaround.patch
-# ezx-serial-bug TODO:
-# does anyone have a phone with this bug?
pxa-kbd.patch
-# pxa-kbd TODO:
-# test multi-key presses
-# ask Harald about driver status/sending mainline
-
a780-kbd.patch
e680-kbd.patch
@@ -60,6 +58,7 @@ pcap-ts.patch
a780-ts.patch
e680-ts.patch
a1200-ts.patch
+e6-ts.patch
ezx-backlight.patch
@@ -83,6 +82,11 @@ mux-fix-tty-driver.patch
mux-linux-2.6.21-fix.patch
#mux-ifdef-ezx-features.patch
#mux_debug.patch
+
+asoc-pxa-ssp.patch
+asoc-fix-loopback.patch
+ezx-asoc.patch
+
# mux_cli TODO:
# merge patches
# try to understand the code and cleanup (painful)
@@ -92,6 +96,8 @@ mux-linux-2.6.21-fix.patch
# can NOT run as module (yet)
# pxa-ohci, ts0710_mux, ts0710_mux_usb, ezx-bp
+# the folowing break too much stuff on other phones.
+# i2c-core-fix-a1200.patch (see ezx-eoc.c)
+# pxa27x-udc-fix-a1200.patch (see ezx-a1200.c)
+
# incomplete
-asoc-pxa-ssp.patch
-ezx-asoc.patch