aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-07-15 17:54:04 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-07-15 17:54:04 +0000
commitbc7b93c0a21620236efd37d36db62ec41f0754f9 (patch)
treedd24845a0091c7cf36665365358cee4f8850a25c /packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
parent1ce456a505016e6d879b0b99118cb79629bd354e (diff)
downloadopenembedded-bc7b93c0a21620236efd37d36db62ec41f0754f9.tar.gz
ep93xx-kernel: add derevo20, drop old stuff
Diffstat (limited to 'packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb')
-rw-r--r--packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb58
1 files changed, 58 insertions, 0 deletions
diff --git a/packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb b/packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
new file mode 100644
index 0000000000..fa95d66dc6
--- /dev/null
+++ b/packages/linux/ep93xx-kernel_2.6.17+2.6.18-rc1.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Linux Kernel for Cirrus Logic ep39xx compatible machines"
+SECTION = "kernel"
+MAINTAINER = "Koen Kooi <koen@dominion.kabel.utwente.nl>"
+LICENSE = "GPL"
+PR = "r0"
+
+COMPATIBLE_MACHINE = "ep93xx"
+
+SRC_URI = "ftp://ftp.kernel.org/pub/linux/kernel/v2.6/linux-2.6.17.tar.bz2 \
+ http://ftp.kernel.org/pub/linux/kernel/v2.6/testing/patch-2.6.18-rc1.bz2;patch=1 \
+ http://ftp.kernel.org/pub/linux/kernel/v2.6/snapshots/patch-2.6.18-rc1-git9.bz2;patch=1 \
+ http://www.wantstofly.org/~buytenh/ep93xx/derevo20.diff;pnum=1;patch=1 \
+ file://defconfig \
+ "
+
+S = "${WORKDIR}/linux-2.6.17"
+
+inherit kernel
+
+KERNEL_IMAGETYPE = "zImage"
+
+
+
+do_configure() {
+ rm -f ${S}/.config
+
+ if [ ! -e ${WORKDIR}/defconfig ]; then
+ die "No default configuration for ${MACHINE} available."
+ fi
+
+
+ if [ "${TARGET_OS}" == "linux-gnueabi" ]; then
+ echo "CONFIG_AEABI=y" >> ${S}/.config
+ echo "CONFIG_OABI_COMPAT=y" >> ${S}/.config
+ else
+ echo "# CONFIG_AEABI is not set" >> ${S}/.config
+ echo "# CONFIG_OABI_COMPAT is not set" >> ${S}/.config
+ fi
+
+ sed -e '/CONFIG_AEABI/d' \
+ -e '/CONFIG_OABI_COMPAT=/d' \
+ '${WORKDIR}/defconfig' >>'${S}/.config'
+
+ yes '' | oe_runmake oldconfig
+
+
+}
+
+do_deploy() {
+ install -d ${DEPLOY_DIR_IMAGE}
+ install -m 0644 arch/${ARCH}/boot/${KERNEL_IMAGETYPE} ${DEPLOY_DIR_IMAGE}/${KERNEL_IMAGETYPE}-${PV}-${MACHINE}-${DATETIME}
+}
+
+do_deploy[dirs] = "${S}"
+
+addtask deploy before do_build after do_compile
+
+