aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorPhil Blundell <philb@gnu.org>2005-06-27 11:50:31 +0000
committerPhil Blundell <philb@gnu.org>2005-06-27 11:50:31 +0000
commitb648d920524b7fa165dd09c4500531bf62140270 (patch)
tree5c42e7d69e7ae1e471a3cdd1e68aef141e3fc5d3 /packages/linux-libc-headers
parentb333193073c79d62b0f17c23ba4d82347e2dc210 (diff)
downloadopenembedded-b648d920524b7fa165dd09c4500531bf62140270.tar.gz
Merge bk://oe-devel@openembedded-devel.bkbits.net/openembedded
into mill.internal.reciva.com:/nexus/home/pb/oe/oe 2005/06/27 12:45:36+01:00 reciva.com!pb package and ship linux-libc-headers from here, since glibc doesn't actually include them in libc6-dev BKrev: 42bfe807rZohvjKqdf_rO3P_Puxq3w
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb64
1 files changed, 64 insertions, 0 deletions
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
index e69de29bb2..c7d6367c7b 100644
--- a/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.11.1.bb
@@ -0,0 +1,64 @@
+SECTION = "devel"
+DESCRIPTION = "Sanitized set of 2.6 kernel headers for the C library's use."
+HOMEPAGE = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/"
+# license note from the package:
+# Linux-libc-headers are derived from linux kernel headers. For license of a
+# particular header, check it's content, and if copyright notice isn't present,
+# standard linux kernel license applies.
+# since we assume GPL for linux i think we can also assume it here
+LICENSE = "GPL"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+INHIBIT_DEFAULT_DEPS = "1"
+PR = "r1"
+
+SRC_URI = "http://ep09.pld-linux.org/~mmazur/linux-libc-headers/linux-libc-headers-${PV}.tar.bz2 \
+ file://keyboard.patch;patch=1"
+
+S = "${WORKDIR}/linux-libc-headers-${PV}"
+
+do_configure () {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=ppc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ esac
+ if test ! -e include/asm-$ARCH; then
+ oefatal unable to create asm symlink in kernel headers
+ fi
+ cp -a "include/asm-$ARCH" "include/asm"
+ if test "$ARCH" = "arm"; then
+ cp -a include/asm/arch-ebsa285 include/asm/arch
+ elif test "$ARCH" = "sh"; then
+ cp -a include/asm/cpu-${TARGET_ARCH} include/asm/cpu || die "unable to create include/asm/cpu"
+ fi
+}
+
+do_stage () {
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm
+ cp -pfLR include/linux ${STAGING_INCDIR}/
+ cp -pfLR include/asm ${STAGING_INCDIR}/
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/linux
+ rm -rf ${CROSS_DIR}/${TARGET_SYS}/include/asm
+ install -d ${CROSS_DIR}/${TARGET_SYS}/include
+ cp -pfLR include/linux ${CROSS_DIR}/${TARGET_SYS}/include/
+ cp -pfLR include/asm ${CROSS_DIR}/${TARGET_SYS}/include/
+}
+
+do_install() {
+ install -d ${D}${includedir}
+ cp -pfLR include/linux ${D}${includedir}/
+ cp -pfLR include/asm ${D}${includedir}/
+}
+