aboutsummaryrefslogtreecommitdiffstats
path: root/packages/linux-libc-headers
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2008-05-24 06:54:02 +0000
committerKhem Raj <raj.khem@gmail.com>2008-05-24 06:54:02 +0000
commitc59f48d70046a2478b8288cdc956e340176ccbe7 (patch)
treedfddfe997ea4686ef6707ec44c69876e2ce6d999 /packages/linux-libc-headers
parentc8399b4a991c9754c68ce1fd2947684f34d225df (diff)
downloadopenembedded-c59f48d70046a2478b8288cdc956e340176ccbe7.tar.gz
Add 2.6.25 kernel headers.
Diffstat (limited to 'packages/linux-libc-headers')
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.25/.mtn2git_empty0
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.25/fix-kernel-conditionalize-a.out.h.patch15
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.25/procinfo.h24
-rw-r--r--packages/linux-libc-headers/linux-libc-headers-2.6.25/reinstate-a.out.h.patch14
-rw-r--r--packages/linux-libc-headers/linux-libc-headers_2.6.25.bb68
5 files changed, 121 insertions, 0 deletions
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.25/.mtn2git_empty b/packages/linux-libc-headers/linux-libc-headers-2.6.25/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.25/.mtn2git_empty
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.25/fix-kernel-conditionalize-a.out.h.patch b/packages/linux-libc-headers/linux-libc-headers-2.6.25/fix-kernel-conditionalize-a.out.h.patch
new file mode 100644
index 0000000000..30dee5d520
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.25/fix-kernel-conditionalize-a.out.h.patch
@@ -0,0 +1,15 @@
+diff --git a/include/linux/a.out.h b/include/linux/a.out.h
+index 208f4e8..d149699 100644
+--- a/include/linux/a.out.h
++++ b/include/linux/a.out.h
+@@ -1,6 +1,10 @@
+ #ifndef __A_OUT_GNU_H__
+ #define __A_OUT_GNU_H__
+
++#ifndef __KERNEL__
++#define CONFIG_ARCH_SUPPORTS_AOUT
++#endif
++
+ #ifdef CONFIG_ARCH_SUPPORTS_AOUT
+
+ #define __GNU_EXEC_MACROS__
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.25/procinfo.h b/packages/linux-libc-headers/linux-libc-headers-2.6.25/procinfo.h
new file mode 100644
index 0000000000..8cdf828af8
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.25/procinfo.h
@@ -0,0 +1,24 @@
+/*
+ * linux/include/asm-arm/procinfo.h
+ *
+ * Copyright (C) 1996-1999 Russell King
+ *
+ * This program is free software; you can redistribute it and/or modify
+ * it under the terms of the GNU General Public License version 2 as
+ * published by the Free Software Foundation.
+ */
+#ifndef __ASM_PROCINFO_H
+#define __ASM_PROCINFO_H
+
+#define HWCAP_SWP 1
+#define HWCAP_HALF 2
+#define HWCAP_THUMB 4
+#define HWCAP_26BIT 8 /* Play it safe */
+#define HWCAP_FAST_MULT 16
+#define HWCAP_FPA 32
+#define HWCAP_VFP 64
+#define HWCAP_EDSP 128
+#define HWCAP_JAVA 256
+#define HWCAP_IWMMXT 512
+#define HWCAP_CRUNCH 1024
+#endif
diff --git a/packages/linux-libc-headers/linux-libc-headers-2.6.25/reinstate-a.out.h.patch b/packages/linux-libc-headers/linux-libc-headers-2.6.25/reinstate-a.out.h.patch
new file mode 100644
index 0000000000..9032f4e716
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers-2.6.25/reinstate-a.out.h.patch
@@ -0,0 +1,14 @@
+diff --git a/include/linux/Kbuild b/include/linux/Kbuild
+index 93b9885..b6fbb25 100644
+--- a/include/linux/Kbuild
++++ b/include/linux/Kbuild
+@@ -166,6 +166,9 @@ unifdef-y += acct.h
+ unifdef-y += adb.h
+ unifdef-y += adfs_fs.h
+ unifdef-y += agpgart.h
++ifeq ($(wildcard include/asm-$(SRCARCH)/a.out.h),include/asm-$(SRCARCH)/a.out.h)
++unifdef-y += a.out.h
++endif
+ unifdef-y += apm_bios.h
+ unifdef-y += atalk.h
+ unifdef-y += atmdev.h
diff --git a/packages/linux-libc-headers/linux-libc-headers_2.6.25.bb b/packages/linux-libc-headers/linux-libc-headers_2.6.25.bb
new file mode 100644
index 0000000000..f47fd08091
--- /dev/null
+++ b/packages/linux-libc-headers/linux-libc-headers_2.6.25.bb
@@ -0,0 +1,68 @@
+require linux-libc-headers.inc
+
+INHIBIT_DEFAULT_DEPS = "1"
+DEPENDS += "unifdef-native"
+PR = "r1"
+
+SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://reinstate-a.out.h.patch;patch=1 \
+ file://fix-kernel-conditionalize-a.out.h.patch;patch=1 \
+ file://procinfo.h"
+
+S = "${WORKDIR}/linux-${PV}"
+
+set_arch() {
+ case ${TARGET_ARCH} in
+ alpha*) ARCH=alpha ;;
+ arm*) ARCH=arm ;;
+ cris*) ARCH=cris ;;
+ hppa*) ARCH=parisc ;;
+ i*86*) ARCH=i386 ;;
+ ia64*) ARCH=ia64 ;;
+ mips*) ARCH=mips ;;
+ m68k*) ARCH=m68k ;;
+ powerpc*) ARCH=powerpc ;;
+ s390*) ARCH=s390 ;;
+ sh*) ARCH=sh ;;
+ sparc64*) ARCH=sparc64 ;;
+ sparc*) ARCH=sparc ;;
+ x86_64*) ARCH=x86_64 ;;
+ avr32*) ARCH=avr32 ;;
+ bfin*) ARCH=blackfin ;;
+ esac
+}
+
+do_configure() {
+ set_arch
+ oe_runmake allnoconfig ARCH=$ARCH
+}
+
+do_compile () {
+}
+
+do_install() {
+ set_arch
+ oe_runmake headers_install INSTALL_HDR_PATH=${D}${exec_prefix} ARCH=$ARCH
+}
+
+do_install_append_arm() {
+ cp ${WORKDIR}/procinfo.h ${D}${includedir}/asm/
+}
+
+STAGE_TEMP="${WORKDIR}/temp-staging"
+
+do_stage () {
+ set_arch
+ echo $ARCH
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake headers_install INSTALL_HDR_PATH=${STAGE_TEMP}${exec_prefix} ARCH=$ARCH
+ if [ "$ARCH" = "arm" ]; then
+ cp ${WORKDIR}/procinfo.h ${STAGE_TEMP}${includedir}/asm/
+ fi
+ install -d ${STAGING_INCDIR}
+ rm -rf ${STAGING_INCDIR}/linux ${STAGING_INCDIR}/asm ${STAGING_INCDIR}/asm-generic
+ cp -pfLR ${STAGE_TEMP}${includedir}/linux ${STAGING_INCDIR}/
+ cp -pfLR ${STAGE_TEMP}${includedir}/asm ${STAGING_INCDIR}/
+ cp -pfLR ${STAGE_TEMP}${includedir}/asm-generic ${STAGING_INCDIR}/
+}