aboutsummaryrefslogtreecommitdiffstats
path: root/packages/librsync/librsync_0.9.7.bb
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-05-31 01:12:34 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-31 01:12:34 +0000
commit07321325c869378445800aff2546ad0f2121fd05 (patch)
tree34c4920a180dabf4039dbeff049c4f45676d51bf /packages/librsync/librsync_0.9.7.bb
parent8938bf09e6a8642d7843dc036486c888c99ea5d5 (diff)
downloadopenembedded-07321325c869378445800aff2546ad0f2121fd05.tar.gz
librsync 0.9.7; Add librsync - a library that implements the rsync
remote-delta algorithm. Closes bug # 1032.
Diffstat (limited to 'packages/librsync/librsync_0.9.7.bb')
-rw-r--r--packages/librsync/librsync_0.9.7.bb23
1 files changed, 23 insertions, 0 deletions
diff --git a/packages/librsync/librsync_0.9.7.bb b/packages/librsync/librsync_0.9.7.bb
new file mode 100644
index 0000000000..eb8bb2671c
--- /dev/null
+++ b/packages/librsync/librsync_0.9.7.bb
@@ -0,0 +1,23 @@
+DESCRIPTION = "librsync is a free software library that implements the rsync \
+remote-delta algorithm. This algorithm allows efficient remote updates of a \
+file, without requiring the old and new versions to both be present at the \
+sending end."
+HOMEPAGE = "http://librsync.sourceforge.net/"
+SECTION = "libs"
+LICENSE = "LGPL"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/librsync/librsync-${PV}.tar.gz"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--disable-build-docs --enable-shared "
+
+do_stage() {
+ oe_libinstall -a -so -C .libs librsync ${STAGING_LIBDIR}
+ install -d ${STAGING_INCDIR}/
+ for i in librsync.h librsync-config.h
+ do
+ install -m 0644 ${S}/$i ${STAGING_INCDIR}/$i
+ done
+}