aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libgcrypt
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-03-01 16:45:25 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-03-01 16:45:25 +0000
commit4e5bcb9a3dbcb17d5f60c4740fbb3dc058e17a0c (patch)
treef033fda2dbea55627b11ee0d01cf6651966f4445 /packages/libgcrypt
parent3f8a14bc8b63968e904c7b53d83cbd5f09c2ad8b (diff)
downloadopenembedded-4e5bcb9a3dbcb17d5f60c4740fbb3dc058e17a0c.tar.gz
libgcrypt (all) add pkgconfig support to it. patch unmergable since upstream doesn't like pkgconfig *sigh*
Diffstat (limited to 'packages/libgcrypt')
-rw-r--r--packages/libgcrypt/files/.mtn2git_empty0
-rw-r--r--packages/libgcrypt/files/add-pkgconfig-support.patch62
-rw-r--r--packages/libgcrypt/libgcrypt-1.4.0/.mtn2git_empty0
-rw-r--r--packages/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch49
-rw-r--r--packages/libgcrypt/libgcrypt.inc3
-rw-r--r--packages/libgcrypt/libgcrypt_1.2.4.bb (renamed from packages/libgcrypt/libgcrypt_1.2.3.bb)0
6 files changed, 113 insertions, 1 deletions
diff --git a/packages/libgcrypt/files/.mtn2git_empty b/packages/libgcrypt/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libgcrypt/files/.mtn2git_empty
diff --git a/packages/libgcrypt/files/add-pkgconfig-support.patch b/packages/libgcrypt/files/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..9b00e8262a
--- /dev/null
+++ b/packages/libgcrypt/files/add-pkgconfig-support.patch
@@ -0,0 +1,62 @@
+diff -Nur libgcrypt-1.2.4/configure.ac libgcrypt11-1.2.4/configure.ac
+--- libgcrypt-1.2.4/configure.ac 2007-02-01 19:41:06.000000000 +0100
++++ libgcrypt11-1.2.4/configure.ac 2007-02-11 13:05:36.000000000 +0100
+@@ -808,6 +808,7 @@
+ src/Makefile
+ src/gcrypt.h
+ src/libgcrypt-config
++src/libgcrypt.pc
+ tests/Makefile
+ w32-dll/Makefile
+ ])
+diff -Nur libgcrypt-1.2.4/src/libgcrypt.pc.in libgcrypt11-1.2.4/src/libgcrypt.pc.in
+--- libgcrypt-1.2.4/src/libgcrypt.pc.in 1970-01-01 01:00:00.000000000 +0100
++++ libgcrypt11-1.2.4/src/libgcrypt.pc.in 2007-02-11 13:03:30.000000000 +0100
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
++Libs.private: @GPG_ERROR_LIBS@
++Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
+diff -Nur libgcrypt-1.2.4/src/Makefile.am libgcrypt11-1.2.4/src/Makefile.am
+--- libgcrypt-1.2.4/src/Makefile.am 2006-11-30 16:38:18.000000000 +0100
++++ libgcrypt11-1.2.4/src/Makefile.am 2007-02-11 13:10:03.000000000 +0100
+@@ -27,6 +27,11 @@
+
+ lib_LTLIBRARIES = libgcrypt.la
+
++# Pkg-config script.
++pkgconfigdir = $(libdir)/pkgconfig
++pkgconfig_DATA = libgcrypt.pc
++DISTCLEANFILES = $(pkgconfig_DATA)
++
+ if HAVE_LD_VERSION_SCRIPT
+ libgcrypt_version_script_cmd = -Wl,--version-script=$(srcdir)/libgcrypt.vers
+ else
diff --git a/packages/libgcrypt/libgcrypt-1.4.0/.mtn2git_empty b/packages/libgcrypt/libgcrypt-1.4.0/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt-1.4.0/.mtn2git_empty
diff --git a/packages/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch b/packages/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch
new file mode 100644
index 0000000000..dd5917e900
--- /dev/null
+++ b/packages/libgcrypt/libgcrypt-1.4.0/add-pkgconfig-support.patch
@@ -0,0 +1,49 @@
+Index: libgcrypt-1.4.0/configure.ac
+===================================================================
+--- libgcrypt-1.4.0.orig/configure.ac
++++ libgcrypt-1.4.0/configure.ac
+@@ -1072,6 +1072,7 @@ cipher/Makefile
+ doc/Makefile
+ src/Makefile
+ src/gcrypt.h
++src/libgcrypt.pc
+ src/libgcrypt-config
+ src/versioninfo.rc
+ tests/Makefile
+Index: libgcrypt-1.4.0/src/libgcrypt.pc.in
+===================================================================
+--- /dev/null
++++ libgcrypt-1.4.0/src/libgcrypt.pc.in
+@@ -0,0 +1,32 @@
++# Process this file with autoconf to produce a pkg-config metadata file.
++# Copyright (C) 2002, 2003, 2004, 2005, 2006 Free Software Foundation
++# Author: Simon Josefsson
++#
++# This file is free software; as a special exception the author gives
++# unlimited permission to copy and/or distribute it, with or without
++# modifications, as long as this notice is preserved.
++#
++# This file is distributed in the hope that it will be useful, but
++# WITHOUT ANY WARRANTY, to the extent permitted by law; without even the
++# implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
++
++prefix=@prefix@
++exec_prefix=@exec_prefix@
++libdir=@libdir@
++includedir=@includedir@
++
++# API info
++api_version=@LIBGCRYPT_CONFIG_API_VERSION@
++
++# Misc information.
++symmetric_ciphers=@LIBGCRYPT_CIPHERS@
++asymmetric_ciphers=@LIBGCRYPT_PUBKEY_CIPHERS@
++digests=@LIBGCRYPT_DIGESTS@
++
++Name: libgcrypt
++Description: GNU crypto library
++URL: http://www.gnupg.org
++Version: @VERSION@
++Libs: -L${libdir} @LIBGCRYPT_CONFIG_LIBS@
++Libs.private: @GPG_ERROR_LIBS@
++Cflags: -I${includedir} @LIBGCRYPT_CONFIG_CFLAGS@ @GPG_ERROR_CFLAGS@
diff --git a/packages/libgcrypt/libgcrypt.inc b/packages/libgcrypt/libgcrypt.inc
index 2dc2459c09..65f78db647 100644
--- a/packages/libgcrypt/libgcrypt.inc
+++ b/packages/libgcrypt/libgcrypt.inc
@@ -4,7 +4,8 @@ PRIORITY = "optional"
LICENSE = "GPL LGPL FDL"
DEPENDS = "libgpg-error"
-SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz"
+SRC_URI = "ftp://ftp.gnupg.org/gcrypt/libgcrypt/libgcrypt-${PV}.tar.gz \
+ file://add-pkgconfig-support.patch;patch=1"
inherit autotools binconfig pkgconfig
diff --git a/packages/libgcrypt/libgcrypt_1.2.3.bb b/packages/libgcrypt/libgcrypt_1.2.4.bb
index 2fe98d62e3..2fe98d62e3 100644
--- a/packages/libgcrypt/libgcrypt_1.2.3.bb
+++ b/packages/libgcrypt/libgcrypt_1.2.4.bb