aboutsummaryrefslogtreecommitdiffstats
path: root/packages/libaio/libaio_0.3.103.bb
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-04-18 01:36:07 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-18 01:36:07 +0000
commit3cb13e039b0c1686c987315760c812d153e6b399 (patch)
treec49ed4f5c9b6bac53828b1c7a27eaf7674c6e4e6 /packages/libaio/libaio_0.3.103.bb
parentf58b825f8d1319d278df8527bce57bb09958ac19 (diff)
downloadopenembedded-3cb13e039b0c1686c987315760c812d153e6b399.tar.gz
libaio: initial add. Patched for MIPS.
Diffstat (limited to 'packages/libaio/libaio_0.3.103.bb')
-rw-r--r--packages/libaio/libaio_0.3.103.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/packages/libaio/libaio_0.3.103.bb b/packages/libaio/libaio_0.3.103.bb
new file mode 100644
index 0000000000..1930f77c85
--- /dev/null
+++ b/packages/libaio/libaio_0.3.103.bb
@@ -0,0 +1,38 @@
+# libaio .bb build file
+# Copyright (C) 2005-2006, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see /COPYING)
+
+DESCRIPTION="Asynchronous input/output library that uses the kernels native interface"
+HOMEPAGE="https://rhn.redhat.com/errata/RHBA-2005-085.html"
+MAINTAINER = "Raymond Danks <raymondd@ia.amd.com>"
+LICENSE="GPL"
+
+SRC_URI="http://search.belnet.be/packages/lineox/4.0/updates/SRPMS/${P}-3.src.rpm \
+file://${P}-more-arches.patch;patch=1"
+
+S=${WORKDIR}/${P}
+
+FILES_${PN} = "/usr"
+
+inherit kernel-arch
+
+DEPENDS_append = " rpm2cpio-native"
+
+do_unpack() {
+
+ if ! test -f libaio-${PV}.tar.gz ; then
+ rpm2cpio.pl ${DL_DIR}/${P}-3.src.rpm | cpio -i --make-directories
+ tar xzvf libaio-${PV}.tar.gz
+ fi
+}
+
+do_stage () {
+ #make install prefix='${STAGING_DIR}/${TARGET_SYS}'
+ install -D -m 644 src/libaio.h ${STAGING_DIR}/${TARGET_SYS}/include/libaio.h
+ oe_libinstall -so -C src libaio ${STAGING_LIBDIR}
+
+}
+
+do_install () {
+ make install prefix='${D}/usr'
+}