aboutsummaryrefslogtreecommitdiffstats
path: root/packages/lcd4linux
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-01-18 16:59:29 +0100
committerfrans <frans@linux-cdv2.site>2009-01-19 19:43:34 +0100
commit69f5e0b0a5ca89a00f364f604a95cbcf23d45986 (patch)
tree33fbae7854148b7f7b4c8e255b9348552511759f /packages/lcd4linux
parentc9ea9cc59e59635562e718c6f21bb2d42e9545a8 (diff)
downloadopenembedded-69f5e0b0a5ca89a00f364f604a95cbcf23d45986.tar.gz
lcd4lnux updated to 0.11.0-SVN; added --with-ncurses in bb file
Diffstat (limited to 'packages/lcd4linux')
-rw-r--r--packages/lcd4linux/lcd4linux_0.11.0-SVN.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/lcd4linux/lcd4linux_0.11.0-SVN.bb b/packages/lcd4linux/lcd4linux_0.11.0-SVN.bb
new file mode 100644
index 0000000000..01471bdfc1
--- /dev/null
+++ b/packages/lcd4linux/lcd4linux_0.11.0-SVN.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "LCD4Linux is a small program that grabs information from the kernel and some subsystems and displays it on an external liquid crystal display."
+LICENSE = "GPLv2"
+
+DEPENDS = "libusb-compat ncurses readline virtual/libx11"
+
+PV = "0.11.0-SVN"
+PR = "r0"
+
+EXTRA_OECONF = " --with-glib-prefix=${STAGING_LIBDIR}/.. \
+ --with-glib-exec-prefix=${STAGING_LIBDIR}/.. \
+ --with-ncurses=${STAGING_LIBDIR}/.."
+SRC_URI = " http://ssl.bulix.org/projects/lcd4linux/raw-attachment/wiki/Download/lcd4linux-0.11.0-SVN.tar.bz2 \
+ file://lcd4linux.init"
+
+S = "${WORKDIR}/lcd4linux-0.11.0-SVN"
+
+
+inherit autotools update-rc.d
+
+INITSCRIPT_NAME = "lcd4linux"
+CONFFILES_${PN} += "${sysconfdir}/lcd4linux.conf"
+
+do_install_append() {
+ install -d ${D}/${sysconfdir}
+ install -m 0600 ${S}/lcd4linux.conf.sample ${D}/${sysconfdir}/lcd4linux.conf
+ install -d ${D}/${INIT_D_DIR}
+ install -m 0755 ${WORKDIR}/lcd4linux.init ${D}/${INIT_D_DIR}/lcd4linux
+}
+