aboutsummaryrefslogtreecommitdiffstats
path: root/packages/keymaps/keymaps_1.0.bb
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2006-04-07 15:32:51 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-07 15:32:51 +0000
commitddf840bda3e98eff84c09083edf2706c65ec683f (patch)
treefa3b3c46a019a6c23a062aa66f464aed5cc76855 /packages/keymaps/keymaps_1.0.bb
parente06bd5fffaf21706cd5286e0267b6313c4c41d13 (diff)
downloadopenembedded-ddf840bda3e98eff84c09083edf2706c65ec683f.tar.gz
keymaps handling moved from initscripts to keymaps package
- loading keymap require loadkeys from console-tools (which takes 300K) - all Zaurus machines (except collie) will get this package installed - collie 2.4 keymap is the same as kernel one so it is not needed on device anyway users can install it if want to make some changes in mapping Zaurus machines conf: dropped console-tools from RDEPENDS, added keymaps instead - keymaps RDEPEND on console-tools
Diffstat (limited to 'packages/keymaps/keymaps_1.0.bb')
-rw-r--r--packages/keymaps/keymaps_1.0.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/keymaps/keymaps_1.0.bb b/packages/keymaps/keymaps_1.0.bb
new file mode 100644
index 0000000000..4df5df8113
--- /dev/null
+++ b/packages/keymaps/keymaps_1.0.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Keyboard map"
+SECTION = "base"
+MAINTAINER = "Marcin Juszkiewicz <openembedded@hrw.one.pl>"
+RDEPENDS = "initscripts console-tools"
+LICENSE = "GPL"
+PACKAGE_ARCH = "${MACHINE}"
+PR = "r2"
+
+inherit update-rc.d
+
+SRC_URI = "file://keymap"
+
+SRC_URI_append_c7x0 = " file://keymap-*.map"
+SRC_URI_append_tosa = " file://keymap-*.map"
+SRC_URI_append_akita = " file://keymap-*.map"
+SRC_URI_append_spitz = " file://keymap-*.map"
+SRC_URI_append_collie = " file://keymap-*.map"
+SRC_URI_append_poodle = " file://keymap-*.map"
+
+INITSCRIPT_NAME = "keymap"
+INITSCRIPT_PARAMS = "start 00 S ."
+
+do_install () {
+ install -d ${D}${sysconfdir}/init.d/
+ install -m 0755 ${WORKDIR}/keymap ${D}${sysconfdir}/init.d/
+
+ case ${MACHINE} in
+ c7x0 | tosa | spitz | akita | borzoi | collie | poodle )
+ install -m 0644 ${WORKDIR}/keymap-*.map ${D}${sysconfdir}
+ ;;
+ *)
+ ;;
+ esac
+}