aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-11-12 09:02:18 +0000
committerRod Whitby <rod@whitby.id.au>2006-11-12 09:02:18 +0000
commitd1b1231953cce26a8d087a087cc54d83b568c20a (patch)
tree1b7a3b390ab72414f64161d5365700b37c293aeb /packages/images
parentf3088cbe5754d03762722ae4ca05de2063485864 (diff)
downloadopenembedded-d1b1231953cce26a8d087a087cc54d83b568c20a.tar.gz
slugos: Changed SLUGOS_FLASH_IMAGE to be multi-valued, to allow for multiple target upgrade image formats. Changed the image name, so that it overwrites the previously built image (and doesn't fill the autobuilder disks).
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/slugos-image.bb9
-rw-r--r--packages/images/unslung-image.bb3
2 files changed, 7 insertions, 5 deletions
diff --git a/packages/images/slugos-image.bb b/packages/images/slugos-image.bb
index 7073105e24..90a5cefcbe 100644
--- a/packages/images/slugos-image.bb
+++ b/packages/images/slugos-image.bb
@@ -6,11 +6,12 @@
DESCRIPTION = "Generic SlugOS image"
HOMEPAGE = "http://www.nslu2-linux.org"
LICENSE = "MIT"
-PR = "r36"
+PR = "r37"
# SLUGOS_IMAGENAME defines the name of the image to be build, if it
# is not set this package will be skipped!
IMAGE_BASENAME = "${SLUGOS_IMAGENAME}"
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DISTRO_VERSION}"
IMAGE_FSTYPES = "jffs2"
EXTRA_IMAGECMD_jffs2 = "--pad --${SLUGOS_IMAGESEX} --eraseblock=0x20000 -D ${SLUGOS_DEVICE_TABLE}"
IMAGE_LINGUAS = ""
@@ -113,13 +114,13 @@ python () {
# LinkSys have made "EraseAll" available, however, (this does overwrite RedBoot)
# it is a bad idea to produce flash images without a valid RedBoot - that allows
# an innocent user upgrade attempt to instantly brick the NSLU2.
-PACK_IMAGE += "${@['', 'nslu2_pack_image;'][bb.data.getVar('SLUGOS_FLASH_IMAGE', d, 1) == 'yes']}"
-PACK_IMAGE_DEPENDS += "${@['', 'slugimage-native nslu2-linksys-firmware'][bb.data.getVar('SLUGOS_FLASH_IMAGE', d, 1) == 'yes']}"
+PACK_IMAGE += "${@['', 'nslu2_pack_image;'][bb.data.getVar('SLUGOS_FLASH_IMAGE', d, 1) == 'nslu2']}"
+PACK_IMAGE_DEPENDS += "${@['', 'slugimage-native nslu2-linksys-firmware'][bb.data.getVar('SLUGOS_FLASH_IMAGE', d, 1) == 'nslu2']}"
NSLU2_SLUGIMAGE_ARGS ?= ""
nslu2_pack_image() {
- if test '${SLUGOS_FLASH_IMAGE}' = yes
+ if test '${SLUGOS_FLASH_IMAGE}' = nslu2
then
install -d ${DEPLOY_DIR_IMAGE}/slug
install -m 0644 ${STAGING_LIBDIR}/nslu2-binaries/RedBoot \
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index d585414f1f..82ca8313fd 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,7 +1,8 @@
LICENSE = MIT
-PR = "r23"
+PR = "r24"
IMAGE_BASENAME = "unslung"
+IMAGE_NAME = "${IMAGE_BASENAME}-${MACHINE}-${DISTRO_VERSION}"
IMAGE_LINGUAS = ""
USE_DEVFS = "1"