aboutsummaryrefslogtreecommitdiffstats
path: root/packages/images
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2006-11-11 07:12:54 +0000
committerMike Westerhof <mwester@dls.net>2006-11-11 07:12:54 +0000
commit2498ea82a3a37cf46a8063bd712b9cda49645534 (patch)
treecacaeb1a46f87515304968c756d1280d727b28a1 /packages/images
parent3d95f2b6df01d65fe26857c57e638b8480668c53 (diff)
downloadopenembedded-2498ea82a3a37cf46a8063bd712b9cda49645534.tar.gz
Unslung: major change - Linksys busybox now subsumed by slingbox; cpio and find
are no longer required; rc.bootdisk functionality introduced in unslung-rootfs
Diffstat (limited to 'packages/images')
-rw-r--r--packages/images/unslung-image.bb46
1 files changed, 28 insertions, 18 deletions
diff --git a/packages/images/unslung-image.bb b/packages/images/unslung-image.bb
index 1deab932c7..d585414f1f 100644
--- a/packages/images/unslung-image.bb
+++ b/packages/images/unslung-image.bb
@@ -1,5 +1,5 @@
LICENSE = MIT
-PR = "r22"
+PR = "r23"
IMAGE_BASENAME = "unslung"
@@ -10,15 +10,17 @@ DEPENDS = "virtual/kernel \
${UNSLUNG_EXTRA_DEPENDS}"
RDEPENDS = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg libipkg \
- cpio \
- findutils \
+ libc6-unslung slingbox ipkg \
+ libipkg \
+# cpio \
+# findutils \
${UNSLUNG_EXTRA_RDEPENDS}"
IPKG_INSTALL = "kernel update-modules unslung-rootfs \
- libc6-unslung slingbox ipkg libipkg \
- cpio \
- findutils \
+ libc6-unslung slingbox ipkg \
+ libipkg \
+# cpio \
+# findutils \
kernel-module-netconsole \
${UNSLUNG_EXTRA_INSTALL}"
@@ -72,25 +74,26 @@ unslung_clean_image () {
${STRIP} ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
chmod ugo+x ${IMAGE_ROOTFS}/lib/libgcc_s.so.1
+# MJW - experimental right now, but no longer need cpio and find
# We need cpio and find, but we don't need any of the other stuff in
# the packages (users can install the full package with ipkg after
# unsling). Remove the extra files and executables, and clean up
# the entries from the ipkg database manually.
#-- these are for cpio:
- rm -f ${IMAGE_ROOTFS}/usr/bin/mt
- rm -rf ${IMAGE_ROOTFS}/usr/libexec
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/cpio.*
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/alternatives/rmt
- sed -i -e '/^Package: cpio/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
+# rm -f ${IMAGE_ROOTFS}/usr/bin/mt
+# rm -rf ${IMAGE_ROOTFS}/usr/libexec
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/cpio.*
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/alternatives/rmt
+# sed -i -e '/^Package: cpio/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
#-- and these for find:
- rm -f ${IMAGE_ROOTFS}/usr/bin/locate
- rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
- rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
- rm -f ${IMAGE_ROOTFS}/usr/bin/xargs.findutils
- rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/findutils.*
- sed -i -e '/^Package: findutils/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
+# rm -f ${IMAGE_ROOTFS}/usr/bin/locate
+# rm -f ${IMAGE_ROOTFS}/usr/bin/updatedb
+# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs
+# rm -f ${IMAGE_ROOTFS}/usr/bin/xargs.findutils
+# rm -f ${IMAGE_ROOTFS}${libdir}/ipkg/info/findutils.*
+# sed -i -e '/^Package: findutils/,/^$/d' ${IMAGE_ROOTFS}${libdir}/ipkg/status
# FIXME: change made 24 Jul 2006 by the OE folks changes the "strip"
# behavior to create an extra file named .debug/<filename> containing
@@ -107,6 +110,13 @@ unslung_clean_image () {
rm -rf ${IMAGE_ROOTFS}/usr/bin/.debug
rm -rf ${IMAGE_ROOTFS}/usr/sbin/.debug
rm -rf ${IMAGE_ROOTFS}/usr/lib/.debug
+
+# MJW - Experimental - just to make space; remove before releasing!
+# #### Hack to make space for testing! REMOVE THIS!
+# rm -rf ${IMAGE_ROOTFS}/etc/samba/codepages/unicode_map.850
+# rm -rf ${IMAGE_ROOTFS}/bin/ftp
+# #### End of Hack!
+
}
python () {