aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hugs
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2004-12-19 14:48:05 +0000
committerRene Wagner <rw@handhelds.org>2004-12-19 14:48:05 +0000
commit4ced78fc07a64771fc233c9ea928514cce758800 (patch)
tree8750048a15743d899d5882c95c03cf6e8b5d74cc /packages/hugs
parent395d924ff38c311fe7003c6a90f965273d4a6543 (diff)
downloadopenembedded-4ced78fc07a64771fc233c9ea928514cce758800.tar.gz
Merge oe-devel@oe-devel.bkbits.net:openembedded
into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2004/12/19 15:46:46+01:00 dyndns.org!oe hugs: add .desktop and icon BKrev: 41c594a5LUhdHfIRzZxBXu8aprJ7bg
Diffstat (limited to 'packages/hugs')
-rw-r--r--packages/hugs/files/hugs.desktop0
-rw-r--r--packages/hugs/files/hugs.png0
-rw-r--r--packages/hugs/hugs_hugs98-Nov2003.bb31
3 files changed, 31 insertions, 0 deletions
diff --git a/packages/hugs/files/hugs.desktop b/packages/hugs/files/hugs.desktop
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hugs/files/hugs.desktop
diff --git a/packages/hugs/files/hugs.png b/packages/hugs/files/hugs.png
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hugs/files/hugs.png
diff --git a/packages/hugs/hugs_hugs98-Nov2003.bb b/packages/hugs/hugs_hugs98-Nov2003.bb
index e69de29bb2..cc249fc9af 100644
--- a/packages/hugs/hugs_hugs98-Nov2003.bb
+++ b/packages/hugs/hugs_hugs98-Nov2003.bb
@@ -0,0 +1,31 @@
+DEPENDS = "readline"
+SRC_URI = "http://cvs.haskell.org/Hugs/downloads/Nov2003/${PV}.tar.gz \
+ file://hugs.desktop \
+ file://hugs.png"
+LICENSE = "BSD"
+PR = "r1"
+
+S = "${WORKDIR}/${PV}/src/unix"
+
+inherit autotools
+
+# disable STRIP as the generated Makefile falsely call arm-linux-strip
+# on compiling which leads to abortion of the compile
+# we strip manually anyway so disabling it here is 'ok'
+EXTRA_OECONF = "--enable-debug --disable-ffi STRIP=true"
+
+do_configure() {
+ oe_runconf
+}
+
+do_compile() {
+ cd ../ && oe_runmake
+}
+
+do_install() {
+ cd ../ && autotools_do_install
+ install -d ${D}${datadir}/applications/
+ install -m 0644 ${WORKDIR}/hugs.desktop ${D}/${datadir}/applications/
+ install -d ${D}${datadir}/pixmaps/
+ install -m 0644 ${WORKDIR}/hugs.png ${D}${datadir}/pixmaps/
+}