aboutsummaryrefslogtreecommitdiffstats
path: root/packages/hfsutils
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2007-03-15 11:24:01 +0000
committerOyvind Repvik <nail@nslu2-linux.org>2007-03-15 11:24:01 +0000
commit6fd2f7482504103a5bff4df862de152258132df8 (patch)
treefb74ede3f89e28c21a48d80193b15cb93717cdc0 /packages/hfsutils
parent9e0454c007a7237b5e12d2b628495d3329ec2acb (diff)
downloadopenembedded-6fd2f7482504103a5bff4df862de152258132df8.tar.gz
add package hfsutils, thanks to timtimred
Diffstat (limited to 'packages/hfsutils')
-rw-r--r--packages/hfsutils/.mtn2git_empty0
-rw-r--r--packages/hfsutils/hfsutils-3.2.6/.mtn2git_empty0
-rw-r--r--packages/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch13
-rw-r--r--packages/hfsutils/hfsutils-3.2.6/largerthan2gb.patch15
-rw-r--r--packages/hfsutils/hfsutils_3.2.6.bb41
5 files changed, 69 insertions, 0 deletions
diff --git a/packages/hfsutils/.mtn2git_empty b/packages/hfsutils/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hfsutils/.mtn2git_empty
diff --git a/packages/hfsutils/hfsutils-3.2.6/.mtn2git_empty b/packages/hfsutils/hfsutils-3.2.6/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/hfsutils/hfsutils-3.2.6/.mtn2git_empty
diff --git a/packages/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch b/packages/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch
new file mode 100644
index 0000000000..6e25f794b2
--- /dev/null
+++ b/packages/hfsutils/hfsutils-3.2.6/hfsutils-3.2.6-errno.patch
@@ -0,0 +1,13 @@
+diff -ruN hfsutils.orig/tclhfs.c hfsutils-3.2.6/tclhfs.c
+--- hfsutils.orig/tclhfs.c 2003-03-31 17:34:55.000000000 +0200
++++ hfsutils-3.2.6/tclhfs.c 2003-03-31 17:39:51.000000000 +0200
+@@ -43,8 +43,7 @@
+ # include "charset.h"
+ # include "suid.h"
+ # include "version.h"
+-
+-extern int errno;
++# include <errno.h>
+
+ # define ERROR(code, str) (hfs_error = (str), errno = (code))
+
diff --git a/packages/hfsutils/hfsutils-3.2.6/largerthan2gb.patch b/packages/hfsutils/hfsutils-3.2.6/largerthan2gb.patch
new file mode 100644
index 0000000000..423256b67d
--- /dev/null
+++ b/packages/hfsutils/hfsutils-3.2.6/largerthan2gb.patch
@@ -0,0 +1,15 @@
+diff -ruN hfsutils.orig/libhfs/os/unix.c hfsutils-3.2.6/libhfs/os/unix.c
+--- hfsutils.orig/libhfs/os/unix.c 1998-11-02 23:09:13.000000000 +0000
++++ hfsutils-3.2.6/libhfs/os/unix.c 2007-02-27 15:44:21.023442553 +0000
+@@ -19,6 +19,11 @@
+ * $Id: largerthan2gb.patch,v 1.1 2005/02/05 21:20:43 hansmi Exp $
+ */
+
++#ifdef __linux__
++#define _FILE_OFFSET_BITS 64
++#define _LARGE_FILES
++#endif
++
+ # ifdef HAVE_CONFIG_H
+ # include "config.h"
+ # endif
diff --git a/packages/hfsutils/hfsutils_3.2.6.bb b/packages/hfsutils/hfsutils_3.2.6.bb
new file mode 100644
index 0000000000..981c79351b
--- /dev/null
+++ b/packages/hfsutils/hfsutils_3.2.6.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "HFS file system utilities"
+SECTION = "base"
+LICENSE = "GPL"
+PR = "r1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "ftp://ftp.mars.org/pub/hfs/hfsutils-3.2.6.tar.gz \
+ file://hfsutils-3.2.6-errno.patch;patch=1 \
+ file://largerthan2gb.patch;patch=1 \
+ "
+
+do_configure () {
+ oe_runconf --disable-x
+}
+
+do_compile () {
+ oe_runmake
+ cd hfsck; oe_runmake
+}
+
+do_install () {
+ install -d ${D}/usr/bin
+ install -m 755 hfsutil ${D}/usr/bin/hfsutil
+ install -m 755 hfsck/hfsck ${D}/usr/bin/hfsck
+
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hattrib
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hcd
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hcopy
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hdel
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hdir
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hformat
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/his
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hmkdir
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hmount
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hpwd
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hrename
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hrmdir
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/humount
+ ln -sf /usr/bin/hfsutil ${D}/usr/bin/hvol
+}