aboutsummaryrefslogtreecommitdiffstats
path: root/packages/helloworld
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-19 11:29:25 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-19 11:29:25 +0000
commit12a7e1f9f2fafd6741ee680e6457e2be5d5db3e7 (patch)
treeb97a9e84304e3c970fd6b610533f84bd903254b5 /packages/helloworld
parentbd01b197f0d4ade7c9f2d87467de9aa404fe42e3 (diff)
downloadopenembedded-12a7e1f9f2fafd6741ee680e6457e2be5d5db3e7.tar.gz
helloworld: New! A statically compiled hello world.
Diffstat (limited to 'packages/helloworld')
-rw-r--r--packages/helloworld/.mtn2git_empty0
-rw-r--r--packages/helloworld/helloworld_1.0.0.bb50
2 files changed, 50 insertions, 0 deletions
diff --git a/packages/helloworld/.mtn2git_empty b/packages/helloworld/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/helloworld/.mtn2git_empty
diff --git a/packages/helloworld/helloworld_1.0.0.bb b/packages/helloworld/helloworld_1.0.0.bb
new file mode 100644
index 0000000000..99ebc051fd
--- /dev/null
+++ b/packages/helloworld/helloworld_1.0.0.bb
@@ -0,0 +1,50 @@
+DESCRIPTION = "Minimal statically compiled Hello world!"
+LICENSE = "GPL"
+PR = "r0"
+
+S = "${WORKDIR}/${P}"
+
+do_fetch () {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
+}
+
+do_compile () {
+ ${CC} -o helloworld helloworld.c -static
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}/
+ # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
+ # so if a sysvinit is installed, it will be used instead of helloworld
+ install -d ${D}${base_bindir}
+ ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
+}
+
+DESCRIPTION = "Minimal statically compiled Hello world!"
+LICENSE = "GPL"
+PR = "r0"
+
+S = "${WORKDIR}/${P}"
+
+do_fetch () {
+ mkdir -p ${WORKDIR}/${P}
+ cd ${WORKDIR}/${P}
+ echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
+}
+
+do_compile () {
+ ${CC} -o helloworld helloworld.c -static
+}
+
+do_install () {
+ install -d ${D}${bindir}
+ install -m 0755 helloworld ${D}${bindir}/
+ # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
+ # so if a sysvinit is installed, it will be used instead of helloworld
+ install -d ${D}${base_bindir}
+ ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
+}
+