aboutsummaryrefslogtreecommitdiffstats
path: root/packages/helloworld
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-06-10 19:56:10 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-06-10 19:56:10 +0000
commitf3291064aae5357ce7e306db2509f1e330e360e1 (patch)
tree0ec6cebc59ebd0a5e59f1410d5c3a1b74302af1d /packages/helloworld
parent939697d32b98264fc53558aed296989d7aa112fd (diff)
downloadopenembedded-f3291064aae5357ce7e306db2509f1e330e360e1.tar.gz
helloworld 1.0.0: Remove duplicate content.
Diffstat (limited to 'packages/helloworld')
-rw-r--r--packages/helloworld/helloworld_1.0.0.bb26
1 files changed, 0 insertions, 26 deletions
diff --git a/packages/helloworld/helloworld_1.0.0.bb b/packages/helloworld/helloworld_1.0.0.bb
index 99ebc051fd..da4daa408d 100644
--- a/packages/helloworld/helloworld_1.0.0.bb
+++ b/packages/helloworld/helloworld_1.0.0.bb
@@ -22,29 +22,3 @@ do_install () {
install -d ${D}${base_bindir}
ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
}
-
-DESCRIPTION = "Minimal statically compiled Hello world!"
-LICENSE = "GPL"
-PR = "r0"
-
-S = "${WORKDIR}/${P}"
-
-do_fetch () {
- mkdir -p ${WORKDIR}/${P}
- cd ${WORKDIR}/${P}
- echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
-}
-
-do_compile () {
- ${CC} -o helloworld helloworld.c -static
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 helloworld ${D}${bindir}/
- # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
- # so if a sysvinit is installed, it will be used instead of helloworld
- install -d ${D}${base_bindir}
- ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
-}
-