aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gtk-engines
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/gtk-engines
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/gtk-engines')
-rw-r--r--packages/gtk-engines/.mtn2git_empty0
-rw-r--r--packages/gtk-engines/gtk-engines_2.2.0.bb18
-rw-r--r--packages/gtk-engines/gtk-engines_2.6.1.bb28
-rw-r--r--packages/gtk-engines/gtk-engines_2.6.3.bb28
-rw-r--r--packages/gtk-engines/gtk-industrial-engine/.mtn2git_empty0
-rw-r--r--packages/gtk-engines/gtk-industrial-engine/no-gtk1.patch31
-rw-r--r--packages/gtk-engines/gtk-industrial-engine_0.2.36.4.bb22
-rw-r--r--packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb22
8 files changed, 149 insertions, 0 deletions
diff --git a/packages/gtk-engines/.mtn2git_empty b/packages/gtk-engines/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gtk-engines/.mtn2git_empty
diff --git a/packages/gtk-engines/gtk-engines_2.2.0.bb b/packages/gtk-engines/gtk-engines_2.2.0.bb
index e69de29bb2..1e93abc936 100644
--- a/packages/gtk-engines/gtk-engines_2.2.0.bb
+++ b/packages/gtk-engines/gtk-engines_2.2.0.bb
@@ -0,0 +1,18 @@
+LICENSE = GPL
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "gtk+"
+
+PACKAGES += " gtk-engine-pixmap gtk-engine-redmond95 gtk-engine-metal gtk-theme-metal gtk-theme-redmond95"
+FILES_gtk-engine-pixmap = "${libdir}/gtk-2.0/*/engines/libpixmap.so"
+FILES_gtk-engine-redmond95 = "${libdir}/gtk-2.0/*/engines/libredmond95.so"
+FILES_gtk-engine-metal = "${libdir}/gtk-2.0/*/engines/libmetal.so"
+FILES_gtk-theme-redmond95 = "${datadir}/themes/Redmond95"
+FILES_gtk-theme-metal = "${datadir}/themes/Metal"
+DEPENDS_gtk-theme-redmond95 = "gtk-engine-redmond95"
+DEPENDS_gtk-theme-metal = "gtk-engine-metal"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.2/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
diff --git a/packages/gtk-engines/gtk-engines_2.6.1.bb b/packages/gtk-engines/gtk-engines_2.6.1.bb
index e69de29bb2..d75701757e 100644
--- a/packages/gtk-engines/gtk-engines_2.6.1.bb
+++ b/packages/gtk-engines/gtk-engines_2.6.1.bb
@@ -0,0 +1,28 @@
+LICENSE = GPL
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "gtk+"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), "gtk-2.0/2.4.0/engines")
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+
diff --git a/packages/gtk-engines/gtk-engines_2.6.3.bb b/packages/gtk-engines/gtk-engines_2.6.3.bb
index e69de29bb2..d75701757e 100644
--- a/packages/gtk-engines/gtk-engines_2.6.3.bb
+++ b/packages/gtk-engines/gtk-engines_2.6.3.bb
@@ -0,0 +1,28 @@
+LICENSE = GPL
+SECTION = "x11/base"
+DESCRIPTION = "GTK theme engines"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+DEPENDS = "gtk+"
+
+RDEPENDS_gtk-theme-redmond = "gtk-engine-redmond95"
+RDEPENDS_gtk-theme-metal = "gtk-engine-metal"
+RDEPENDS_gtk-theme-mist = "gtk-engine-mist"
+RDEPENDS_gtk-theme-crux = "gtk-engine-crux-engine"
+RDEPENDS_gtk-theme-lighthouseblue = "gtk-engine-lighthouseblue"
+RDEPENDS_gtk-theme-thinice = "gtk-engine-thinice"
+RDEPENDS_gtk-theme-industrial = "gtk-engine-industrial"
+
+SRC_URI = "${GNOME_MIRROR}/${PN}/2.6/${PN}-${PV}.tar.bz2"
+
+inherit autotools pkgconfig
+
+python populate_packages_prepend() {
+ import os.path
+
+ engines_root = os.path.join(bb.data.getVar('libdir', d, 1), "gtk-2.0/2.4.0/engines")
+ themes_root = os.path.join(bb.data.getVar('datadir', d, 1), "themes")
+
+ do_split_packages(d, engines_root, '^lib(.*)\.so$', 'gtk-engine-%s', 'GTK %s theme engine', extra_depends='')
+ do_split_packages(d, themes_root, '(.*)', 'gtk-theme-%s', 'GTK theme %s', allow_dirs=True, extra_depends='')
+}
+
diff --git a/packages/gtk-engines/gtk-industrial-engine/.mtn2git_empty b/packages/gtk-engines/gtk-industrial-engine/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/gtk-engines/gtk-industrial-engine/.mtn2git_empty
diff --git a/packages/gtk-engines/gtk-industrial-engine/no-gtk1.patch b/packages/gtk-engines/gtk-industrial-engine/no-gtk1.patch
index e69de29bb2..ad3d681694 100644
--- a/packages/gtk-engines/gtk-industrial-engine/no-gtk1.patch
+++ b/packages/gtk-engines/gtk-industrial-engine/no-gtk1.patch
@@ -0,0 +1,31 @@
+--- gtk-industrial-engine-0.2.36.2/configure.ac.old 2004-11-28 16:48:45.000000000 +0000
++++ gtk-industrial-engine-0.2.36.2/configure.ac 2004-11-28 16:48:54.000000000 +0000
+@@ -27,11 +27,6 @@
+ AC_SUBST(GTK2_LIBS)
+ AC_SUBST(GTK2_VERSION)
+
+-AM_PATH_GTK(1.2.9, ,
+- AC_MSG_ERROR([*** GTK+-1.2.9 not installed - please install first ***]))AC_CHECK_LIB(gtk, gtk_style_set_prop_experimental, :,
+- AC_MSG_ERROR([*** gtk_style_set_prop_experimental() not found; perhaps you have an old CVS version of GTK+ ***]),
+- $GTK_LIBS)
+-
+ AC_CONFIG_FILES([
+ Makefile
+ icons/24x24/apps/Makefile
+@@ -56,8 +51,6 @@
+ icons/192x192/apps/Makefile
+ icons/192x192/filesystems/Makefile
+ icons/192x192/Makefile
+-gtk1-engine/Makefile
+-gtk1-engine/gtk/Makefile
+ gtk2-engine/Makefile
+ gtk2-engine/gtk-2.0/Makefile
+ gtk2-engine/gtk-2.0/gtkrc
+--- gtk-industrial-engine-0.2.36.2/Makefile.am.old 2004-11-28 16:49:02.000000000 +0000
++++ gtk-industrial-engine-0.2.36.2/Makefile.am 2004-11-28 16:49:08.000000000 +0000
+@@ -1,4 +1,4 @@
+-SUBDIRS = icons gtk1-engine gtk2-engine metacity po
++SUBDIRS = icons gtk2-engine metacity po
+
+ THEME_IN_FILES=index.theme.in
+
diff --git a/packages/gtk-engines/gtk-industrial-engine_0.2.36.4.bb b/packages/gtk-engines/gtk-industrial-engine_0.2.36.4.bb
index e69de29bb2..78700b91a2 100644
--- a/packages/gtk-engines/gtk-industrial-engine_0.2.36.4.bb
+++ b/packages/gtk-engines/gtk-industrial-engine_0.2.36.4.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+
diff --git a/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb b/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
index e69de29bb2..78700b91a2 100644
--- a/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
+++ b/packages/gtk-engines/gtk-industrial-engine_0.2.36.5.bb
@@ -0,0 +1,22 @@
+SECTION = "x11/base"
+DESCRIPTION = "Industrial theme engine for GTK"
+MAINTAINER = "Phil Blundell <pb@handhelds.org>"
+LICENSE = "GPL2"
+DEPENDS = "gtk+"
+
+SRC_URI = "${DEBIAN_MIRROR}/main/g/gtk-industrial-engine/gtk-industrial-engine_${PV}.tar.gz \
+ file://no-gtk1.patch;patch=1"
+
+PACKAGES += "gtk-theme-industrial"
+FILES_${PN} = "${libdir}/gtk-2.0/*/engines/*.so"
+FILES_${PN}-dev = "${libdir}/gtk-2.0/*/engines/*"
+FILES_gtk-theme-industrial = "${datadir}/icons ${datadir}/themes"
+
+inherit autotools
+
+do_configure_prepend() {
+ for i in `ls gtk-common`; do
+ ln -sf ../gtk-common/$i gtk2-engine/$i
+ done
+}
+