aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gstreamer
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2006-09-13 15:31:52 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2006-09-13 15:31:52 +0000
commit17429c0e3721b71e4556feb47fa4096fa1a0004e (patch)
treed01ef6b6bee280005e90d57beafc86ac96873c67 /packages/gstreamer
parent6a725d10543a5e8e9ebcb4af3a4c795754a8ad3b (diff)
parent35fa52c32306f5661aada3a6e742583fa5499b03 (diff)
downloadopenembedded-17429c0e3721b71e4556feb47fa4096fa1a0004e.tar.gz
merge of '362d00084fcab0dc4cba423bee3c23d68532cb36'
and '52dfcd4e8a176e28df32baa61ee5584aa8d4c9c6'
Diffstat (limited to 'packages/gstreamer')
-rw-r--r--packages/gstreamer/gst-plugins-base_0.10.6.bb2
-rw-r--r--packages/gstreamer/gst-plugins-base_0.10.7.bb7
-rw-r--r--packages/gstreamer/gst-plugins-ugly_0.10.4.bb2
-rw-r--r--packages/gstreamer/gstreamer_0.10.8.bb31
4 files changed, 40 insertions, 2 deletions
diff --git a/packages/gstreamer/gst-plugins-base_0.10.6.bb b/packages/gstreamer/gst-plugins-base_0.10.6.bb
index 5d5108788b..48e24bf756 100644
--- a/packages/gstreamer/gst-plugins-base_0.10.6.bb
+++ b/packages/gstreamer/gst-plugins-base_0.10.6.bb
@@ -1,2 +1,2 @@
-include gst-plugins.inc
+require gst-plugins.inc
PROVIDES_${PN} += "gst-plugins"
diff --git a/packages/gstreamer/gst-plugins-base_0.10.7.bb b/packages/gstreamer/gst-plugins-base_0.10.7.bb
index 5d5108788b..1679ecb1ca 100644
--- a/packages/gstreamer/gst-plugins-base_0.10.7.bb
+++ b/packages/gstreamer/gst-plugins-base_0.10.7.bb
@@ -1,2 +1,7 @@
-include gst-plugins.inc
+require gst-plugins.inc
PROVIDES_${PN} += "gst-plugins"
+
+do_stage() {
+ autotools_stage_all
+}
+
diff --git a/packages/gstreamer/gst-plugins-ugly_0.10.4.bb b/packages/gstreamer/gst-plugins-ugly_0.10.4.bb
new file mode 100644
index 0000000000..7c548acf7d
--- /dev/null
+++ b/packages/gstreamer/gst-plugins-ugly_0.10.4.bb
@@ -0,0 +1,2 @@
+require gst-plugins.inc
+DEPENDS += "gst-plugins-base"
diff --git a/packages/gstreamer/gstreamer_0.10.8.bb b/packages/gstreamer/gstreamer_0.10.8.bb
new file mode 100644
index 0000000000..251eb42a5d
--- /dev/null
+++ b/packages/gstreamer/gstreamer_0.10.8.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "GStreamer is a multimedia framework for encoding and decoding video and sound. \
+It supports a wide range of formats including mp3, ogg, avi, mpeg and quicktime."
+SECTION = "multimedia"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+HOMEPAGE = "http://www.gstreamer.net/"
+MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
+DEPENDS = "libxml2 glib-2.0 gettext-native popt"
+
+PR = "r0"
+# until we have decided a final naming scheme,
+# don't use this package as a replacement for
+# version 0.8
+DEFAULT_PREFERENCE = "-1"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://gstreamer.freedesktop.org/src/gstreamer/gstreamer-${PV}.tar.bz2"
+EXTRA_OECONF = "--disable-docs-build --disable-dependency-tracking --with-check=no"
+
+do_stage() {
+ oe_runmake install prefix=${STAGING_DIR} \
+ bindir=${STAGING_BINDIR} \
+ includedir=${STAGING_INCDIR} \
+ libdir=${STAGING_LIBDIR} \
+ datadir=${STAGING_DATADIR} \
+ mandir=${STAGING_DIR}/share/man
+}
+
+FILES_${PN} += " ${libdir}/gstreamer-0.10/*.so"
+FILES_${PN}-dev += " ${libdir}/gstreamer-0.10/*.la ${libdir}/gstreamer-0.10/*.a"