aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpio-event/gpio-event/makefile.patch
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-01-10 10:44:13 +0100
committerKoen Kooi <koen@openembedded.org>2009-01-10 10:44:13 +0100
commitd076ad3dbeac4bf7a58a335348c1560dd23799a7 (patch)
treef402fe30741bb8ea76d0f411a1179c6ac937be76 /packages/gpio-event/gpio-event/makefile.patch
parent06af67f2e653d6b0d45117f9aaad0b25db1eaa67 (diff)
downloadopenembedded-d076ad3dbeac4bf7a58a335348c1560dd23799a7.tar.gz
gumstix utils: add char-driver, gpio-event, i2c and microwindows
Diffstat (limited to 'packages/gpio-event/gpio-event/makefile.patch')
-rw-r--r--packages/gpio-event/gpio-event/makefile.patch26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/gpio-event/gpio-event/makefile.patch b/packages/gpio-event/gpio-event/makefile.patch
new file mode 100644
index 0000000000..e1b7fe31b9
--- /dev/null
+++ b/packages/gpio-event/gpio-event/makefile.patch
@@ -0,0 +1,26 @@
+--- gpio-event/Makefile.orig 2008-03-09 13:59:07.000000000 -0600
++++ gpio-event/Makefile 2008-03-09 13:59:51.000000000 -0600
+@@ -19,10 +19,10 @@
+
+ PWD := $(shell pwd)
+
+-GUMSTIX_BUILDROOT = $(PWD)/../cx-1575
+-BUILD_ARM = $(wildcard $(GUMSTIX_BUILDROOT)/build_arm*)
+-KERNELDIR ?= $(wildcard $(BUILD_ARM)/linux-*)
+-CROSS_COMPILE = $(BUILD_ARM)/staging_dir/bin/arm-linux-
++#GUMSTIX_BUILDROOT = $(PWD)/../cx-1575
++#BUILD_ARM = $(wildcard $(GUMSTIX_BUILDROOT)/build_arm*)
++#KERNELDIR ?= $(wildcard $(BUILD_ARM)/linux-*)
++#CROSS_COMPILE = $(BUILD_ARM)/staging_dir/bin/arm-linux-
+
+ default: user-apps kernel-module
+
+@@ -31,7 +31,7 @@
+ user-apps: gpio-event
+
+ TARGET_ARCH=-Os -march=armv5te -mtune=xscale -Wa,-mcpu=xscale
+-CC = $(CROSS_COMPILE)gcc
++#CC = $(CROSS_COMPILE)gcc
+
+ CPPFLAGS +=
+ CFLAGS += -Wall