aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-02-12 20:46:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-12 20:46:53 +0000
commit484abdf495a9061e584691d93708078d6d0ef8f2 (patch)
treeacd3439b5874bcfd4fdecae2e6f41cc459eaef6b /packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
parent8f7d24559543565f314077459f5031c0d34d9220 (diff)
downloadopenembedded-484abdf495a9061e584691d93708078d6d0ef8f2.tar.gz
gpe-bootsplash: Add an opie-theme
Diffstat (limited to 'packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb')
-rw-r--r--packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb35
1 files changed, 35 insertions, 0 deletions
diff --git a/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb b/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
new file mode 100644
index 0000000000..dff92e75c3
--- /dev/null
+++ b/packages/gpe-bootsplash/gpe-bootsplash-theme-opie.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "An Enlightenment theme for gpe-bootsplash"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Matthias 'CoreDump' Hentges <oe@hentges.net>"
+LICENSE = "GPL"
+
+DEPENDS = "gpe-bootsplash"
+RDEPENDS = "gpe-bootsplash"
+
+PR = "r0"
+
+export THEME = "opie"
+
+SRC_URI = "file://*.svg \
+ file://*${THEME}*logo*"
+
+FILES_${PN} = "/usr/share/gpe/splash-${THEME}-*\
+ /usr/share/gpe/${THEME}-logo.png"
+
+
+do_install(){
+ install -d "${D}/usr/share/gpe"
+ install -m 0644 ${WORKDIR}/splash-${THEME}* ${D}/usr/share/gpe
+ install -m 0644 ${WORKDIR}/${THEME}-logo.png ${D}/usr/share/gpe
+}
+
+pkg_postinst() {
+ update-alternatives --install /usr/share/gpe/splash-l.svg bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg 20
+ update-alternatives --install /usr/share/gpe/splash-p.svg bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg 20
+}
+
+pkg_postrm() {
+ update-alternatives --remove bootsplash-l /usr/share/gpe/splash-${THEME}-landscape.svg
+ update-alternatives --remove bootsplash-p /usr/share/gpe/splash-${THEME}-portrait.svg
+}