aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2008-09-18 12:48:11 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2008-09-18 12:48:11 +0000
commitadc5f6e3789c09772a73a8c1904c9e25edf7947f (patch)
tree636a438c181412166a3df2d68154ca4327b883d9 /packages/gcc
parent1bc9e97244776941b12cb6968b016c4e3716f5ed (diff)
downloadopenembedded-adc5f6e3789c09772a73a8c1904c9e25edf7947f.tar.gz
gcc: fix missing mode flags when opening response file
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-3.4.5/libstdc++-v3-open_missing_mode.patch13
-rw-r--r--packages/gcc/gcc_3.4.5.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/packages/gcc/gcc-3.4.5/libstdc++-v3-open_missing_mode.patch b/packages/gcc/gcc-3.4.5/libstdc++-v3-open_missing_mode.patch
new file mode 100644
index 0000000000..3d674c8c59
--- /dev/null
+++ b/packages/gcc/gcc-3.4.5/libstdc++-v3-open_missing_mode.patch
@@ -0,0 +1,13 @@
+from https://hardened.gentooexperimental.org/secure/raw-attachment/ticket/29/libstdc%2B%2B-v3-open_missing_mode.patch
+diff -Nru /var/tmp/portage/sys-libs/libstdc++-v3-3.3.6/work/gcc-3.3.6/gcc/collect2.c /root/hardened/gcc-3.3.6/gcc/collect2.c
+--- gcc-3.3.6/gcc/collect2.c 2003-12-08 20:02:39.000000000 +0100
++++ gcc-3.3.6/gcc/collect2.c 2008-06-19 01:04:21.000000000 +0200
+@@ -1572,7 +1572,7 @@
+ if (redir)
+ {
+ /* Open response file. */
+- redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT);
++ redir_handle = open (redir, O_WRONLY | O_TRUNC | O_CREAT, S_IRUSR | S_IWUSR);
+
+ /* Duplicate the stdout and stderr file handles
+ so they can be restored later. */
diff --git a/packages/gcc/gcc_3.4.5.bb b/packages/gcc/gcc_3.4.5.bb
index 286e656874..b90cd0abce 100644
--- a/packages/gcc/gcc_3.4.5.bb
+++ b/packages/gcc/gcc_3.4.5.bb
@@ -25,5 +25,6 @@ SRC_URI = "${GNU_MIRROR}/gcc/gcc-${PV}/gcc-${PV}.tar.bz2 \
SRC_URI += "file://gcc34-configure.in.patch;patch=1"
SRC_URI += "file://gcc34-thumb-support.patch;patch=1"
+SRC_URI += "file://libstdc++-v3-open_missing_mode.patch;patch=1"
include gcc3-build.inc