aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gcc
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2006-04-08 13:29:28 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-08 13:29:28 +0000
commit49bef915164972bd19f96233ea14da84d5aea4cb (patch)
treeec5ebc872027363371a36181d4f55563266952d1 /packages/gcc
parent66bd2df663e254b07143af810d05caf94acf94bd (diff)
downloadopenembedded-49bef915164972bd19f96233ea14da84d5aea4cb.tar.gz
gcc-cross-4.1.0: add package
Diffstat (limited to 'packages/gcc')
-rw-r--r--packages/gcc/gcc-cross_4.1.0.bb18
1 files changed, 18 insertions, 0 deletions
diff --git a/packages/gcc/gcc-cross_4.1.0.bb b/packages/gcc/gcc-cross_4.1.0.bb
new file mode 100644
index 0000000000..4b0b5a1311
--- /dev/null
+++ b/packages/gcc/gcc-cross_4.1.0.bb
@@ -0,0 +1,18 @@
+include gcc_${PV}.bb
+# path mangling, needed by the cross packaging
+include gcc-paths-cross.inc
+inherit cross
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
+# NOTE: split PR. If the main .oe changes something that affects its *build*
+# remember to increment this one too.
+PR = "r1"
+
+DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
+PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
+
+# cross build
+include gcc3-build-cross.inc
+# cross packaging
+include gcc-package-cross.inc
+
+EXTRA_OECONF += "--with-mpfr=${STAGING_DIR}/${BUILD_SYS}"