aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gawk
diff options
context:
space:
mode:
authorRene Wagner <rw@handhelds.org>2005-08-26 22:12:18 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-26 22:12:18 +0000
commitc6e84a3d8fd3f8047ff2079df7861ccd62985fe3 (patch)
tree266db06d3db1171fe3bdab1a37f2deeb769d8478 /packages/gawk
parent97aba39798f9b3c670b8aa4d5f3ac83baa6b3014 (diff)
downloadopenembedded-c6e84a3d8fd3f8047ff2079df7861ccd62985fe3.tar.gz
gawk: add -native variant.
Diffstat (limited to 'packages/gawk')
-rw-r--r--packages/gawk/gawk-native_3.1.4.bb16
1 files changed, 16 insertions, 0 deletions
diff --git a/packages/gawk/gawk-native_3.1.4.bb b/packages/gawk/gawk-native_3.1.4.bb
new file mode 100644
index 0000000000..dcfca421de
--- /dev/null
+++ b/packages/gawk/gawk-native_3.1.4.bb
@@ -0,0 +1,16 @@
+INHIBIT_AUTOTOOLS_DEPS = "1"
+include gawk_${PV}.bb
+
+inherit native
+
+DEPENDS = ""
+PATCH_DEPENDS = ""
+PATCHCLEANCMD = ""
+PATCHCMD = "num='%s'; name='%s'; file='%s'; patch -p "$num" -i "$file""
+
+S = "${WORKDIR}/gawk-${PV}"
+
+do_stage() {
+ install -d ${STAGING_BINDIR}
+ install -m 755 gawk ${STAGING_BINDIR}
+}