aboutsummaryrefslogtreecommitdiffstats
path: root/packages/gaim
diff options
context:
space:
mode:
authorPhilipp Zabel <philipp.zabel@gmail.com>2006-02-25 00:16:17 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-25 00:16:17 +0000
commitf64674d824f94bfac71bc9768e7052614a1a41d8 (patch)
treefdc15bdfd53bf3f22bfec5ef246cb77d8a2a0499 /packages/gaim
parentd5b9611884d58e949f2a1bae85ea80fac9ce8fae (diff)
downloadopenembedded-f64674d824f94bfac71bc9768e7052614a1a41d8.tar.gz
gaim-cvs: make the gevolution plugin compile against eds-dbus
Diffstat (limited to 'packages/gaim')
-rw-r--r--packages/gaim/files/gevolution-eds-dbus.patch53
-rw-r--r--packages/gaim/gaim_cvs.bb1
2 files changed, 54 insertions, 0 deletions
diff --git a/packages/gaim/files/gevolution-eds-dbus.patch b/packages/gaim/files/gevolution-eds-dbus.patch
new file mode 100644
index 0000000000..0b7479d4f7
--- /dev/null
+++ b/packages/gaim/files/gevolution-eds-dbus.patch
@@ -0,0 +1,53 @@
+--- gaim/plugins/gevolution/gevolution.c.orig 2006-02-23 23:30:25.000000000 +0100
++++ gaim/plugins/gevolution/gevolution.c 2006-02-23 23:31:42.000000000 +0100
+@@ -38,17 +38,12 @@
+
+-#include <libedata-book/Evolution-DataServer-Addressbook.h>
+
+-#include <libebook/e-book-listener.h>
+-#include <libedata-book/e-data-book-factory.h>
+-#include <bonobo/bonobo-main.h>
++#include <libebook/e-book-view-listener.h>
++#include <libebook/e-data-book-factory-bindings.h>
+
+ #include <glib.h>
+
+ #define GEVOLUTION_PLUGIN_ID "gtk-x11-gevolution"
+
+-#define E_DATA_BOOK_FACTORY_OAF_ID \
+- "OAFIID:GNOME_Evolution_DataServer_BookFactory"
+-
+ enum
+ {
+ COLUMN_AUTOADD,
+@@ -324,8 +320,6 @@
+ static gboolean
+ plugin_load(GaimPlugin *plugin)
+ {
+- bonobo_activate();
+-
+ backup_blist_ui_ops = gaim_blist_get_ui_ops();
+
+ blist_ui_ops = g_memdup(backup_blist_ui_ops, sizeof(GaimBlistUiOps));
+@@ -370,7 +364,6 @@
+ static void
+ plugin_destroy(GaimPlugin *plugin)
+ {
+- bonobo_debug_shutdown();
+ }
+
+ static void
+@@ -563,13 +556,6 @@
+ * So, in conclusion, this is an evil hack, but it doesn't harm anything
+ * and it works.
+ */
+- g_module_make_resident(plugin->handle);
+-
+- if (!bonobo_init_full(NULL, NULL, bonobo_activation_orb_get(),
+- CORBA_OBJECT_NIL, CORBA_OBJECT_NIL))
+- {
+- gaim_debug_error("evolution", "Unable to initialize bonobo.\n");
+- }
+ }
+
+ GAIM_INIT_PLUGIN(gevolution, init_plugin, info)
diff --git a/packages/gaim/gaim_cvs.bb b/packages/gaim/gaim_cvs.bb
index faf707a867..921fb7c261 100644
--- a/packages/gaim/gaim_cvs.bb
+++ b/packages/gaim/gaim_cvs.bb
@@ -5,6 +5,7 @@ PV = "2.0+cvs-${SRCDATE}"
SRC_URI = "cvs://anonymous@cvs.sourceforge.net/cvsroot/gaim;module=gaim \
file://no-superimposed-version-on-logo.patch;patch=1 \
file://gtk-deprecated-2.0.0.patch;patch=1 \
+ file://gevolution-eds-dbus.patch;patch=1 \
"
include gaim.inc