aboutsummaryrefslogtreecommitdiffstats
path: root/packages/frotz
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/frotz
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/frotz')
-rw-r--r--packages/frotz/files/Makefile-2.43.patch29
-rw-r--r--packages/frotz/files/Makefile.patch12
-rw-r--r--packages/frotz/files/remove_root_restriction.patch18
-rw-r--r--packages/frotz/frotz_2.42.bb24
-rw-r--r--packages/frotz/frotz_2.43.bb23
5 files changed, 0 insertions, 106 deletions
diff --git a/packages/frotz/files/Makefile-2.43.patch b/packages/frotz/files/Makefile-2.43.patch
deleted file mode 100644
index 7df2576ef1..0000000000
--- a/packages/frotz/files/Makefile-2.43.patch
+++ /dev/null
@@ -1,29 +0,0 @@
---- ./Makefile 2002-10-27 18:21:52.000000000 -0700
-+++ ./Makefile-2.43.patch 2004-09-11 09:33:35.000000000 -0700
-@@ -73,15 +73,15 @@
- # curses library won't work, comment out the first option and uncomment
- # the second.
- #
--CURSES = -lcurses
--#CURSES = -lncurses
-+# CURSES = -lcurses
-+CURSES = -lncurses
-
- # Uncomment this if your need to use ncurses instead of the
- # vendor-supplied curses library. This just tells the compile process
- # which header to include, so don't worry if ncurses is all you have
- # (like on Linux). You'll be fine.
- #
--#CURSES_DEF = -DUSE_NCURSES_H
-+CURSES_DEF = -DUSE_NCURSES_H
-
- # Uncomment this if you're compiling Unix Frotz on a machine that lacks
- # the memmove(3) system call. If you don't know what this means, leave it
-@@ -213,7 +213,6 @@
- fi
-
- install: $(NAME)
-- strip $(BINNAME)$(EXTENSION)
- install -d $(PREFIX)/bin
- install -d $(MAN_PREFIX)/man/man6
- install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
diff --git a/packages/frotz/files/Makefile.patch b/packages/frotz/files/Makefile.patch
deleted file mode 100644
index 4486c127bd..0000000000
--- a/packages/frotz/files/Makefile.patch
+++ /dev/null
@@ -1,12 +0,0 @@
-*** ./Makefile Sat Mar 9 17:24:16 2002
---- ./Makefile.patch Tue Aug 3 10:30:33 2004
-***************
-*** 123,129 ****
- install: $(BINNAME)
- install -d $(PREFIX)/bin
- install -d $(MAN_PREFIX)/man/man6
-- strip $(BINNAME)$(EXTENSION)
- install -c -m 755 $(BINNAME)$(EXTENSION) $(PREFIX)/bin
- install -c -m 644 $(BINNAME).6 $(MAN_PREFIX)/man/man6
-
---- 123,128 ----
diff --git a/packages/frotz/files/remove_root_restriction.patch b/packages/frotz/files/remove_root_restriction.patch
deleted file mode 100644
index f2be13dec2..0000000000
--- a/packages/frotz/files/remove_root_restriction.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- ./src/curses/ux_init.c 2004-09-11 10:15:07.000000000 -0700
-+++ ux_init.c.patch 2004-09-11 10:15:40.000000000 -0700
-@@ -139,15 +139,6 @@
- char *home;
- char configfile[FILENAME_MAX + 1];
-
-- if ((getuid() == 0) || (geteuid() == 0)) {
-- printf("I won't run as root!\n");
-- exit(1);
-- }
--
-- if ((home = getenv("HOME")) == NULL) {
-- printf("Hard drive on fire!\n");
-- exit(1);
-- }
-
- /*
- * It doesn't look like Frotz can reliably be resized given its current
diff --git a/packages/frotz/frotz_2.42.bb b/packages/frotz/frotz_2.42.bb
deleted file mode 100644
index 8daa6c514e..0000000000
--- a/packages/frotz/frotz_2.42.bb
+++ /dev/null
@@ -1,24 +0,0 @@
-LICENSE = "GPL"
-DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
-HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
-SECTION = "console/games"
-DEPENDS = "ncurses"
-
-SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
- file://Makefile.patch;patch=1 "
-
-do_configure() {
- patch -N ${s}/ux_init.c < remove_root_restriction.patch || :
- rm -f ${SourceTree}/frotz.conf
-}
-
-EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
-
-do_compile() {
- oe_runmake frotz
- sed 's/^[a-z]/#&/' frotz.conf-big > frotz.conf;
-}
-
-do_install() {
- oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
-}
diff --git a/packages/frotz/frotz_2.43.bb b/packages/frotz/frotz_2.43.bb
deleted file mode 100644
index 9cace09992..0000000000
--- a/packages/frotz/frotz_2.43.bb
+++ /dev/null
@@ -1,23 +0,0 @@
-LICENSE = "GPL"
-DESCRIPTION = "Frotz is an interpreter for Infocom games and other Z-machine games."
-HOMEPAGE = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/"
-SECTION = "console/games"
-DEPENDS = "ncurses"
-
-SRC_URI = "http://www.cs.csubak.edu/~dgriffi/proj/frotz/files/frotz-${PV}.tar.gz \
- file://Makefile-${PV}.patch;patch=1 \
- file://remove_root_restriction.patch;patch=1 "
-
-do_configure() {
- rm -f ${SourceTree}/frotz.conf
-}
-
-EXTRA_OEMAKE = "CC='${CC}' INCL='${CFLAGS}' LIB='${LDFLAGS}' PREFIX=${prefix} CONFIG_DIR=${sysconfdir}"
-
-do_compile() {
- oe_runmake frotz
-}
-
-do_install() {
- oe_runmake PREFIX=${D}${prefix} MAN_PREFIX=${D}${mandir} install
-}