aboutsummaryrefslogtreecommitdiffstats
path: root/packages/freesmartphone
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-07-22 22:08:12 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-07-22 22:08:12 +0000
commitb9a2e959e83bb0666928feada5c18a75c2f175c7 (patch)
tree275ff8f34c5da6ba6415adbcc214dbc6416fa7af /packages/freesmartphone
parentc09bcfd9e2540cad34c26d3407585e65ea53ec11 (diff)
downloadopenembedded-b9a2e959e83bb0666928feada5c18a75c2f175c7.tar.gz
add illume-theme-freesmartphone
Diffstat (limited to 'packages/freesmartphone')
-rw-r--r--packages/freesmartphone/illume-theme-freesmartphone_git.bb27
1 files changed, 27 insertions, 0 deletions
diff --git a/packages/freesmartphone/illume-theme-freesmartphone_git.bb b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
new file mode 100644
index 0000000000..2d881214a0
--- /dev/null
+++ b/packages/freesmartphone/illume-theme-freesmartphone_git.bb
@@ -0,0 +1,27 @@
+DESCRIPTION = "Illume theme for the freesmartphone.org project"
+HOMEPAGE = "http://illume.projects.openmoko.org/"
+LICENSE = "MIT/BSD"
+PV = "0.0+gitr${SRCREV}"
+PR = "r0"
+
+SRC_URI = "${FREESMARTPHONE_GIT}/artwork.git;protocol=git;branch=master"
+S = "${WORKDIR}/git/illume"
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/init/
+
+ # Make illume the default profile
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+}
+
+RPROVIDES_${PN} = "illume-theme"
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+PACKAGE_ARCH_${PN} = "all"
+