aboutsummaryrefslogtreecommitdiffstats
path: root/packages/e17
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-15 21:23:29 +0200
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2008-10-16 14:26:17 +0200
commit772e59441bb0a133b9412eb9deacf817a6eb1b8c (patch)
tree387fc9842ee66a43b640f34333d3532c0bec0732 /packages/e17
parent03becd2a2973c1f0b03a12a3329f35b8cd81be0d (diff)
downloadopenembedded-772e59441bb0a133b9412eb9deacf817a6eb1b8c.tar.gz
add illume-theme-illume (from raster)
Diffstat (limited to 'packages/e17')
-rw-r--r--packages/e17/illume-theme-illume_svn.bb33
1 files changed, 33 insertions, 0 deletions
diff --git a/packages/e17/illume-theme-illume_svn.bb b/packages/e17/illume-theme-illume_svn.bb
new file mode 100644
index 0000000000..eb313e074c
--- /dev/null
+++ b/packages/e17/illume-theme-illume_svn.bb
@@ -0,0 +1,33 @@
+DESCRIPTION = "Illume theme for Illume E module"
+HOMEPAGE = "http://www.enlightenment.org/"
+LICENSE = "MIT/BSD"
+DEPENDS = "edje-native eet-native"
+PV = "0.0+${PR}-svnr${SRCREV}"
+PR = "r1"
+
+SRC_URI = "svn://svn.enlightenment.org/svn/e/trunk;module=THEMES/b_and_w;proto=http"
+S = "${WORKDIR}/THEMES/b_and_w"
+
+do_compile() {
+ edje_cc illume.edc
+ edje_cc illume_init.edc
+}
+
+do_install() {
+ install -d ${D}${sysconfdir}/enlightenment
+ install -d ${D}${datadir}/enlightenment/data/themes/
+ install -d ${D}${datadir}/enlightenment/data/init/
+
+ # FIXME: hack. should modify profile.cfg and nto use enlightenment_start.oe
+ echo 'E_PROFILE="-profile illume"' > ${D}${sysconfdir}/enlightenment/default_profile
+
+ install -m 0644 ${S}/illume.edj ${D}${datadir}/enlightenment/data/themes/
+ install -m 0644 ${S}/illume_init.edj ${D}${datadir}/enlightenment/data/init/
+}
+
+RPROVIDES_${PN} = "illume-theme"
+CONFFILES_${PN} = "${sysconfdir}/enlightenment/default_profile"
+FILES_${PN} = "${sysconfdir}/enlightenment ${datadir}/enlightenment"
+
+PACKAGE_ARCH_${PN} = "all"
+