aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dtnrg
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-01-12 15:22:07 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-01-12 15:22:07 +0000
commit3ad50ef778fcdc29cb5fd48109e95d7a8a73fab8 (patch)
treec0d912e296db0e9a5133ffe72586e3a273cc3340 /packages/dtnrg
parenta517ea6a648846d845040be42b024666e6782915 (diff)
downloadopenembedded-3ad50ef778fcdc29cb5fd48109e95d7a8a73fab8.tar.gz
add dtn, from the Delay Tolerant Networking Research Group
yes, this includes python-dtn (of course :)
Diffstat (limited to 'packages/dtnrg')
-rw-r--r--packages/dtnrg/.mtn2git_empty0
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb58
2 files changed, 58 insertions, 0 deletions
diff --git a/packages/dtnrg/.mtn2git_empty b/packages/dtnrg/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/dtnrg/.mtn2git_empty
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
new file mode 100644
index 0000000000..a1111f18e7
--- /dev/null
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -0,0 +1,58 @@
+DESCRIPTION = "Delay Tolerant Networking Package"
+HOMEPAGE = "http://www.dtnrg.org/wiki"
+SECTION = "libs"
+DEPENDS = "db openssl python-native xerces-c"
+LICENSE = "Apache"
+SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --with-python=${STAGING_BINDIR_NATIVE}/python \
+ --with-db=${STAGING_DIR} \
+ --with-tcl=${STAGING_DIR} \
+ --without-google-perftools \
+ --without-bluez \
+ --without-bonjour \
+ --with-expat=${STAGING_DIR} \
+ --with-xerces-c=${STAGING_DIR} \
+ --without-tclreadline \
+ --with-zlib=${STAGING_DIR} \
+ --without-xsd-tool \
+ --with-db=${STAGING_DIR} \
+ --enable-ecl \
+ --enable-edp \
+ --without-mysql \
+ --without-postgres \
+ --with-openssl=${STAGING_DIR} \
+"
+
+def python_dir(d):
+ import os, bb
+ staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
+ if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
+ if os.path.exists( "%s/python2.4" % staging_incdir ): return "python2.4"
+ if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
+ raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
+
+PYTHON_DIR = "${@python_dir(d)}"
+
+export BUILD_SYS
+export HOST_SYS
+
+do_configure_prepend() {
+ for i in aclocal/*.ac oasys/aclocal/*.ac; do
+ install -m 0644 $i ${STAGING_DATADIR}/aclocal/`basename $i`.m4
+ done
+ autotools_do_configure
+}
+
+do_install_append() {
+ cd applib/python
+ INCDIR=../.. LIBDIR=.. VERSION=${PV} python setup.py install --prefix=${D}/${prefix} --install-data=${D}/${datadir}
+}
+
+PACKAGES += "${PN}-python"
+FILES_${PN}-python = "${libdir}/${PYTHON_DIR}"
+RDEPENDS_${PN}-python = "python-core"
+FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"