aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dtnrg
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2008-02-28 12:36:25 +0000
committerRichard Purdie <rpurdie@rpsys.net>2008-02-28 12:36:25 +0000
commit1554e0ea2afcb6b3e8eb1e17294d02fb41624615 (patch)
tree62c7d9c7df31002617a73c015aad51fa9051dcce /packages/dtnrg
parentdb5c3ccdabd9f493a2266d20c6db243057a9e369 (diff)
downloadopenembedded-1554e0ea2afcb6b3e8eb1e17294d02fb41624615.tar.gz
dtnrg: Improve staging variables
Diffstat (limited to 'packages/dtnrg')
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb19
1 files changed, 10 insertions, 9 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index 5975a29e7c..3878829ce5 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -3,29 +3,30 @@ HOMEPAGE = "http://www.dtnrg.org/wiki"
SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
-SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
-PR = "r2"
+SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz \
+ file://configure_fix.patch;patch=1"
+PR = "r3"
inherit autotools
EXTRA_OECONF = "\
--with-python=${STAGING_BINDIR_NATIVE}/python \
- --with-db=${STAGING_DIR} \
- --with-tcl=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-tcl=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-google-perftools \
--without-bluez \
--without-bonjour \
- --with-expat=${STAGING_DIR} \
- --with-xerces-c=${STAGING_DIR} \
+ --with-expat=${STAGING_DIR_HOST}${layout_exec_prefix} \
+ --with-xerces-c=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-tclreadline \
- --with-zlib=${STAGING_DIR} \
+ --with-zlib=${STAGING_DIR_HOST}${layout_exec_prefix} \
--without-xsd-tool \
- --with-db=${STAGING_DIR} \
+ --with-db=${STAGING_DIR_HOST}${layout_exec_prefix} \
--enable-ecl \
--enable-edp \
--without-mysql \
--without-postgres \
- --with-openssl=${STAGING_DIR} \
+ --with-openssl=${STAGING_DIR_HOST}${layout_exec_prefix} \
"
def dtn_python_dir(d):