aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dtnrg
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-01-13 15:56:31 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-01-13 15:56:31 +0000
commit1504dc24a72738bffc41ac3254acff63585edf63 (patch)
treec33b0dfac0079796d955c73ae3cc82bdd12f6fdb /packages/dtnrg
parente389db6955bdb477cae726fc97ca1c6d2f53fab0 (diff)
downloadopenembedded-1504dc24a72738bffc41ac3254acff63585edf63.tar.gz
dtn 2.5.0 use syntax compatible w/ bitbake 1.8.8 for now
Diffstat (limited to 'packages/dtnrg')
-rw-r--r--packages/dtnrg/dtn_2.5.0.bb15
1 files changed, 10 insertions, 5 deletions
diff --git a/packages/dtnrg/dtn_2.5.0.bb b/packages/dtnrg/dtn_2.5.0.bb
index 0b4043bbc2..208c19d381 100644
--- a/packages/dtnrg/dtn_2.5.0.bb
+++ b/packages/dtnrg/dtn_2.5.0.bb
@@ -4,6 +4,7 @@ SECTION = "libs"
DEPENDS = "db openssl python-native xerces-c"
LICENSE = "Apache"
SRC_URI = "http://www.dtnrg.org/docs/code/dtn_${PV}.tgz"
+PR = "r1"
inherit autotools
@@ -27,7 +28,7 @@ EXTRA_OECONF = "\
--with-openssl=${STAGING_DIR} \
"
-def python_dir(d):
+def dtn_python_dir(d):
import os, bb
staging_incdir = bb.data.getVar( "STAGING_INCDIR", d, 1 )
if os.path.exists( "%s/python2.5" % staging_incdir ): return "python2.5"
@@ -35,10 +36,14 @@ def python_dir(d):
if os.path.exists( "%s/python2.3" % staging_incdir ): return "python2.3"
raise "No Python in STAGING_INCDIR. Forgot to build python-native ?"
-PYTHON_DIR = "${@python_dir(d)}"
+PYTHON_DIR = "${@dtn_python_dir(d)}"
-export BUILD_SYS
-export HOST_SYS
+# use this syntax once everyone has at least bitbake 1.8.9
+#export BUILD_SYS
+#export HOST_SYS
+
+export BUILD_SYS:="${BUILD_SYS}"
+export HOST_SYS:="${HOST_SYS}"
do_configure_prepend() {
for i in aclocal/*.ac oasys/aclocal/*.ac; do
@@ -54,7 +59,7 @@ do_install_append() {
PACKAGES += "python-dtn"
DESCRIPTION_python-dtn = "Python bindings to the DTN API"
-PR_python-dtn = "ml1"
+PR_python-dtn = "ml2"
FILES_python-dtn = "${libdir}/${PYTHON_DIR}"
RDEPENDS_python-dtn = "python-core"
FILES_${PN}-dbg += "${libdir}/${PYTHON_DIR}/site-packages/.debug"