aboutsummaryrefslogtreecommitdiffstats
path: root/packages/dash
diff options
context:
space:
mode:
authorDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
committerDenys Dmytriyenko <denis@denix.org>2009-03-17 14:32:59 -0400
commit709c4d66e0b107ca606941b988bad717c0b45d9b (patch)
tree37ee08b1eb308f3b2b6426d5793545c38396b838 /packages/dash
parentfa6cd5a3b993f16c27de4ff82b42684516d433ba (diff)
downloadopenembedded-709c4d66e0b107ca606941b988bad717c0b45d9b.tar.gz
rename packages/ to recipes/ per earlier agreement
See links below for more details: http://thread.gmane.org/gmane.comp.handhelds.openembedded/21326 http://thread.gmane.org/gmane.comp.handhelds.openembedded/21816 Signed-off-by: Denys Dmytriyenko <denis@denix.org> Acked-by: Mike Westerhof <mwester@dls.net> Acked-by: Philip Balister <philip@balister.org> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Marcin Juszkiewicz <hrw@openembedded.org> Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
Diffstat (limited to 'packages/dash')
-rw-r--r--packages/dash/dash_0.5.2.bb30
-rw-r--r--packages/dash/files/makefile-build-cc.diff29
2 files changed, 0 insertions, 59 deletions
diff --git a/packages/dash/dash_0.5.2.bb b/packages/dash/dash_0.5.2.bb
deleted file mode 100644
index ee4e8c1bd6..0000000000
--- a/packages/dash/dash_0.5.2.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "The Debian Almquist Shell is a POSIX compliant shell that is much smaller than 'bash'."
-PROVIDES = "virtual/sh"
-LICENSE = "BSD GPL"
-PR = "r1"
-
-SRC_URI = "http://ftp.debian.org/debian/pool/main/d/dash/dash_${PV}.orig.tar.gz \
- http://snapshot.debian.net/archive/2005/07/11/debian/pool/main/d/dash/dash_0.5.2-6.diff.gz;patch=1 \
- file://makefile-build-cc.diff;patch=1"
-
-inherit autotools
-
-bindir = "/bin"
-PREFIX="${bindir}"
-
-# dont use update-alternatives class because since we are dealing with /bin/sh
-# we need to do the remove in pkg_prerm where the /bin/sh link still points
-# to something (postrm is a shell script)
-
-ALTERNATIVE_NAME = "sh"
-ALTERNATIVE_PATH = "${bindir}/dash"
-ALTERNATIVE_PRIORITY = "10"
-ALTERNATIVE_LINK = "${bindir}/${ALTERNATIVE_NAME}"
-
-pkg_postinst() {
-update-alternatives --install ${ALTERNATIVE_LINK} ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH} ${ALTERNATIVE_PRIORITY}
-}
-
-pkg_prerm() {
-update-alternatives --remove ${ALTERNATIVE_NAME} ${ALTERNATIVE_PATH}
-}
diff --git a/packages/dash/files/makefile-build-cc.diff b/packages/dash/files/makefile-build-cc.diff
deleted file mode 100644
index 8ffd6c2c37..0000000000
--- a/packages/dash/files/makefile-build-cc.diff
+++ /dev/null
@@ -1,29 +0,0 @@
---- dash-0.5.1/src/Makefile.am.orig 2004-07-03 05:13:27.000000000 +0200
-+++ dash-0.5.1/src/Makefile.am 2005-01-11 11:14:11.896299544 +0100
-@@ -3,6 +3,7 @@
- AM_CPPFLAGS = -include $(top_builddir)/config.h
- AM_YFLAGS = -d
-
-+BUILD_CC ?= gcc
- CFLAGS = -g -O2 -Wall
- DEFS = \
- -DBSD=1 -DSMALL -DSHELL \
-@@ -35,6 +36,18 @@
- mktokens mkbuiltins builtins.def mkinit.c \
- mknodes.c nodetypes nodes.c.pat mksyntax.c mksignames.c
-
-+mknodes:
-+ $(BUILD_CC) mknodes.c -o mknodes
-+
-+mksyntax:
-+ $(BUILD_CC) mksyntax.c -o mksyntax
-+
-+mkinit:
-+ $(BUILD_CC) mkinit.c -o mkinit
-+
-+mksignames:
-+ $(BUILD_CC) mksignames.c -o mksignames
-+
- token.h: mktokens
- sh $^
-