aboutsummaryrefslogtreecommitdiffstats
path: root/packages/coreutils
diff options
context:
space:
mode:
authorStanislav Brabec <utx@penguin.cz>2007-07-18 17:54:17 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-07-18 17:54:17 +0000
commit697c6f1d580d46cfb87e0813fa3fc5a05a5bb790 (patch)
tree16587c5752dc4a7e2260a6241da5a934f1e262c2 /packages/coreutils
parent0772c3749d33cf0a5858f5d966ab5f2cb8a8ae7e (diff)
downloadopenembedded-697c6f1d580d46cfb87e0813fa3fc5a05a5bb790.tar.gz
coreutils 0.5.3: fix build issue with glibc-6 bug #2553
* bumped revision to r2 * applied patch from Stanislav Brabec <utx@penguin.cz> * fixes bug http://bugs.openembedded.org/show_bug.cgi?id=2553
Diffstat (limited to 'packages/coreutils')
-rw-r--r--packages/coreutils/coreutils-5.3.0/futimens.patch44
-rw-r--r--packages/coreutils/coreutils_5.3.0.bb5
2 files changed, 47 insertions, 2 deletions
diff --git a/packages/coreutils/coreutils-5.3.0/futimens.patch b/packages/coreutils/coreutils-5.3.0/futimens.patch
new file mode 100644
index 0000000000..3cb2b6ab32
--- /dev/null
+++ b/packages/coreutils/coreutils-5.3.0/futimens.patch
@@ -0,0 +1,44 @@
+Index: coreutils-5.3.0/lib/utimens.c
+===================================================================
+--- coreutils-5.3.0.orig/lib/utimens.c 2005-01-03 22:19:15.000000000 +0000
++++ coreutils-5.3.0/lib/utimens.c 2007-07-01 19:12:32.000000000 +0000
+@@ -55,8 +55,8 @@
+ If TIMESPEC is null, set the time stamps to the current time. */
+
+ int
+-futimens (int fd ATTRIBUTE_UNUSED,
+- char const *file, struct timespec const timespec[2])
++gl_futimens (int fd ATTRIBUTE_UNUSED,
++ char const *file, struct timespec const timespec[2])
+ {
+ /* There's currently no interface to set file timestamps with
+ nanosecond resolution, so do the best we can, discarding any
+@@ -117,5 +117,5 @@
+ int
+ utimens (char const *file, struct timespec const timespec[2])
+ {
+- return futimens (-1, file, timespec);
++ return gl_futimens (-1, file, timespec);
+ }
+Index: coreutils-5.3.0/lib/utimens.h
+===================================================================
+--- coreutils-5.3.0.orig/lib/utimens.h 2004-11-23 20:54:33.000000000 +0000
++++ coreutils-5.3.0/lib/utimens.h 2007-07-01 19:12:37.000000000 +0000
+@@ -1,3 +1,3 @@
+ #include "timespec.h"
+-int futimens (int, char const *, struct timespec const [2]);
++int gl_futimens (int, char const *, struct timespec const [2]);
+ int utimens (char const *, struct timespec const [2]);
+Index: coreutils-5.3.0/src/touch.c
+===================================================================
+--- coreutils-5.3.0.orig/src/touch.c 2004-11-23 20:54:35.000000000 +0000
++++ coreutils-5.3.0/src/touch.c 2007-07-01 19:11:52.000000000 +0000
+@@ -191,7 +191,7 @@
+ t = timespec;
+ }
+
+- ok = (futimens (fd, file, t) == 0);
++ ok = (gl_futimens (fd, file, t) == 0);
+ if (fd != -1)
+ ok &= (close (fd) == 0);
+
diff --git a/packages/coreutils/coreutils_5.3.0.bb b/packages/coreutils/coreutils_5.3.0.bb
index 61d25543ab..42ac2c15af 100644
--- a/packages/coreutils/coreutils_5.3.0.bb
+++ b/packages/coreutils/coreutils_5.3.0.bb
@@ -1,12 +1,13 @@
require coreutils.inc
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://alpha.gnu.org/gnu/coreutils/coreutils-${PV}.tar.bz2 \
file://install-cross.patch;patch=1;pnum=0 \
file://man.patch;patch=1 \
file://rename-tee-for-glibc2.5.patch;patch=1 \
- file://uptime-pow-lib.patch;patch=1"
+ file://uptime-pow-lib.patch;patch=1 \
+ file://futimens.patch;patch=1"
# [ gets a special treatment and is not included in this
bindir_progs = "basename cksum comm csplit cut dir dircolors dirname du \