aboutsummaryrefslogtreecommitdiffstats
path: root/packages/busybox
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2008-11-29 20:23:19 -0600
committerMike Westerhof <mwester@dls.net>2008-11-29 20:23:19 -0600
commit9572f13632296a0b39ff0ea40556d8889f061764 (patch)
treea920aeeffcd32b0ac1abe8a86dae32e3722e36e5 /packages/busybox
parent6818e22214c56ce8a668f24a7a1f12921dbbaa76 (diff)
downloadopenembedded-9572f13632296a0b39ff0ea40556d8889f061764.tar.gz
busybox-1.11.3: fix segfault with fdisk command
(cherrypicked patch from newer busybox version)
Diffstat (limited to 'packages/busybox')
-rw-r--r--packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch12
-rw-r--r--packages/busybox/busybox_1.11.3.bb3
2 files changed, 14 insertions, 1 deletions
diff --git a/packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch b/packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch
new file mode 100644
index 0000000000..633153f1ce
--- /dev/null
+++ b/packages/busybox/busybox-1.11.3/fdisk_lineedit_segfault.patch
@@ -0,0 +1,12 @@
+--- old/libbb/lineedit.c 2008/09/27 01:28:56 23530
++++ new/libbb/lineedit.c 2008/11/02 00:41:05 23898
+@@ -1412,7 +1412,8 @@
+ if ((state->flags & SAVE_HISTORY) && state->hist_file)
+ load_history(state->hist_file);
+ #endif
+- state->cur_history = state->cnt_history;
++ if (state->flags & DO_HISTORY)
++ state->cur_history = state->cnt_history;
+
+ /* prepare before init handlers */
+ cmdedit_y = 0; /* quasireal y, not true if line > xt*yt */
diff --git a/packages/busybox/busybox_1.11.3.bb b/packages/busybox/busybox_1.11.3.bb
index 790bf518cc..08a4531daa 100644
--- a/packages/busybox/busybox_1.11.3.bb
+++ b/packages/busybox/busybox_1.11.3.bb
@@ -1,10 +1,11 @@
require busybox.inc
-PR = "r0"
+PR = "r1"
SRC_URI = "\
http://www.busybox.net/downloads/busybox-${PV}.tar.gz \
\
file://udhcpscript.patch;patch=1 \
+ file://fdisk_lineedit_segfault.patch;patch=1 \
file://busybox-cron \
file://busybox-httpd \
file://busybox-udhcpd \