aboutsummaryrefslogtreecommitdiffstats
path: root/packages/boost/boost-jam-native_3.1.11.bb
diff options
context:
space:
mode:
authorJohn Bowler <jbowler@nslu2-linux.org>2005-11-30 10:53:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-11-30 10:53:57 +0000
commit32a7d2a5419b88a97d291492d729b88e6274036d (patch)
tree50b3cf924e2133063efcbff192768534d7064755 /packages/boost/boost-jam-native_3.1.11.bb
parentb5412bb66cce8ba7780cfe7233056474c4bd4ccc (diff)
downloadopenembedded-32a7d2a5419b88a97d291492d729b88e6274036d.tar.gz
boost-jam-native: release 3.1.11
boost: release 1.33.0
Diffstat (limited to 'packages/boost/boost-jam-native_3.1.11.bb')
-rw-r--r--packages/boost/boost-jam-native_3.1.11.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/boost/boost-jam-native_3.1.11.bb b/packages/boost/boost-jam-native_3.1.11.bb
new file mode 100644
index 0000000000..cf9f2317c8
--- /dev/null
+++ b/packages/boost/boost-jam-native_3.1.11.bb
@@ -0,0 +1,31 @@
+# The Boost web site provides free peer-reviewed portable
+# C++ source libraries. The emphasis is on libraries which
+# work well with the C++ Standard Library. The libraries are
+# intended to be widely useful, and are in regular use by
+# thousands of programmers across a broad spectrum of applications.
+DESCRIPTION = "Make system for boost (native)"
+HOMEPAGE = "http://www.boost.org/"
+MAINTAINER = "John Bowler <jbowler@acm.org>"
+SECTION = "devel"
+PRIORITY = "optional"
+LICENSE = "Boost Software License"
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/boost/boost-jam-${PV}.tgz"
+S = "${WORKDIR}/boost-jam-${PV}"
+
+inherit native
+
+do_compile() {
+ set -ex
+ rm -rf bin.*
+ ./build.sh gcc
+}
+
+# This is too terrible - the build script doesn't give any good
+# way I can see to find out where the binaries are placed, so
+# rely on only one bin.foo directory being created.
+do_stage() {
+ set -ex
+ install -c -m 755 bin.*/bjam ${STAGING_BINDIR}/
+}