aboutsummaryrefslogtreecommitdiffstats
path: root/packages/bluez-libs
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/bluez-libs
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/bluez-libs')
-rw-r--r--packages/bluez-libs/.mtn2git_empty0
-rw-r--r--packages/bluez-libs/bluez-libs_2.14.bb20
-rw-r--r--packages/bluez-libs/bluez-libs_2.15.bb20
3 files changed, 40 insertions, 0 deletions
diff --git a/packages/bluez-libs/.mtn2git_empty b/packages/bluez-libs/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/bluez-libs/.mtn2git_empty
diff --git a/packages/bluez-libs/bluez-libs_2.14.bb b/packages/bluez-libs/bluez-libs_2.14.bb
index e69de29bb2..5814294897 100644
--- a/packages/bluez-libs/bluez-libs_2.14.bb
+++ b/packages/bluez-libs/bluez-libs_2.14.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hci_uart.h hci_vhci.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}
diff --git a/packages/bluez-libs/bluez-libs_2.15.bb b/packages/bluez-libs/bluez-libs_2.15.bb
index e69de29bb2..5814294897 100644
--- a/packages/bluez-libs/bluez-libs_2.15.bb
+++ b/packages/bluez-libs/bluez-libs_2.15.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland Libaries."
+SECTION = "libs"
+PRIORITY = "optional"
+LICENSE = "GPL"
+
+SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
+
+inherit autotools
+
+HEADERS = "bluetooth.h bnep.h cmtp.h hci.h hci_lib.h hci_uart.h hci_vhci.h hidp.h l2cap.h rfcomm.h sco.h sdp.h sdp_lib.h"
+
+do_stage() {
+ oe_libinstall -a -so -C src libbluetooth ${STAGING_LIBDIR}
+
+ install -d ${STAGING_INCDIR}/bluetooth/
+ for f in ${HEADERS}
+ do
+ install -m 0644 include/$f ${STAGING_INCDIR}/bluetooth/$f
+ done
+}