aboutsummaryrefslogtreecommitdiffstats
path: root/packages/avr-evtd/avr-evtd_1.7.2.bb
diff options
context:
space:
mode:
authorTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-22 21:03:57 +0000
committerTim 'timtim' Ellis <tim.ellis@foonas.org>2009-01-22 21:03:57 +0000
commit8ae0d7e99946b21aa404eb61ce49c49d2d237020 (patch)
tree8d86a951d55b298d708e27b0212077598619fe9f /packages/avr-evtd/avr-evtd_1.7.2.bb
parentb5cd58e9ecc3c80e54222368e3c704a0b25d6e90 (diff)
downloadopenembedded-8ae0d7e99946b21aa404eb61ce49c49d2d237020.tar.gz
avr-evtd: Add avr-evtd, LED/button/watchdog stuff for lsppchd, lsppchg and lsmipsel
Diffstat (limited to 'packages/avr-evtd/avr-evtd_1.7.2.bb')
-rw-r--r--packages/avr-evtd/avr-evtd_1.7.2.bb40
1 files changed, 40 insertions, 0 deletions
diff --git a/packages/avr-evtd/avr-evtd_1.7.2.bb b/packages/avr-evtd/avr-evtd_1.7.2.bb
new file mode 100644
index 0000000000..51f8843693
--- /dev/null
+++ b/packages/avr-evtd/avr-evtd_1.7.2.bb
@@ -0,0 +1,40 @@
+DESCRIPTION = "A simple and small user space interface daemon to the Linkstation/Kuro AVR micro-controller"
+HOMEPAGE = "http://sourceforge.net/projects/ppc-evtd"
+SECTION = "console/network"
+PR = "r0"
+LICENSE = "GPL"
+SRC_URI = "${SOURCEFORGE_MIRROR}/ppc-evtd/avr_evtd_${PV}.release.tar.gz \
+ file://dont-ignore-config.patch;patch=1 \
+ file://avr_evtd.conf \
+ file://EventScript \
+ "
+S = "${WORKDIR}/usr/src/avr_evtd"
+
+COMPATIBLE_MACHINE = "(lsppchd|lsppchg|lsmipsel)"
+
+# This is a simple thing, and we will only ever need this for powerpc and mipsel
+# on the platforms above. Pretty important though to stop death by watchdog.
+
+do_compile_powerpc() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o PPC/avr_evtd avr_evtd.c -DNO_MELCO -DUBOOT
+}
+
+do_compile_mipsel() {
+ ${CC} ${CFLAGS} ${LDFLAGS} -o MIPS/avr_evtd avr_evtd.c -DNO_MELCO -DUBOOT -DMIPS
+}
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${sysconfdir}/default
+ install -m 644 ${WORKDIR}/avr_evtd.conf ${D}${sysconfdir}/default/avr_evtd
+ install -d ${D}${sysconfdir}/avr_evtd
+ install -m 755 ${WORKDIR}/EventScript ${D}${sysconfdir}/avr_evtd/EventScript
+}
+
+do_install_append_powerpc() {
+ install -c -m 755 ${S}/PPC/avr_evtd ${D}${sbindir}/avr_evtd
+}
+
+do_install_append_mipsel() {
+ install -c -m 755 ${S}/MIPS/avr_evtd ${D}${sbindir}/avr_evtd
+}