aboutsummaryrefslogtreecommitdiffstats
path: root/packages/apt
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-03-29 11:56:01 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-03-29 11:56:01 +0000
commitedc40a59a0f44223deacd1291e5e80b7b9360897 (patch)
treeb926b25545128093619fded13f3ca2255e1ddd66 /packages/apt
parent59fda25ab6c5091f0f4fd462f54a4555d5f9faf1 (diff)
downloadopenembedded-edc40a59a0f44223deacd1291e5e80b7b9360897.tar.gz
packages/apt/apt_0.6.46.2.bb
packages/apt/apt.inc packages/apt/apt-package.inc : build and package shared libs at all times.
Diffstat (limited to 'packages/apt')
-rw-r--r--packages/apt/apt-package.inc17
-rw-r--r--packages/apt/apt.inc6
-rw-r--r--packages/apt/apt_0.6.46.2.bb3
-rw-r--r--packages/apt/files/environment.patch13
4 files changed, 32 insertions, 7 deletions
diff --git a/packages/apt/apt-package.inc b/packages/apt/apt-package.inc
index 8bf2b56739..5a5d56930e 100644
--- a/packages/apt/apt-package.inc
+++ b/packages/apt/apt-package.inc
@@ -77,11 +77,18 @@ do_install () {
install -m 0755 bin/apt-sortpkgs ${D}${bindir}/
install -m 0755 bin/apt-extracttemplates ${D}${bindir}/
- #eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
- #oe_libinstall -so -C bin libapt-pkg$GLIBC_VER-6 ${D}${libdir}/ || true
- #ln -sf libapt-pkg$GLIBC_VER-6.so ${D}${libdir}/libapt-pkg.so
- #oe_libinstall -so -C bin libapt-inst$GLIBC_VER-6 ${D}${libdir}/ || true
- #ln -sf libapt-inst$GLIBC_VER-6.so ${D}${libdir}/libapt-inst.so
+ install -d ${D}${libdir}
+ eval `cat environment.mak | grep ^GLIBC_VER | sed -e's, = ,=,'`
+ eval `cat apt-pkg/makefile | grep ^MAJOR | sed -e's, = ,=,'`
+ eval `cat apt-pkg/makefile | grep ^MINOR | sed -e's, = ,=,'`
+ install bin/libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
+ ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg$GLIBC_VER-6.so.$MAJOR
+ ln -sf libapt-pkg$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-pkg.so
+ eval `cat apt-inst/makefile | grep ^MAJOR | sed -e's, = ,=,'`
+ eval `cat apt-inst/makefile | grep ^MINOR | sed -e's, = ,=,'`
+ install bin/libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/
+ ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst$GLIBC_VER-6.so.$MAJOR
+ ln -sf libapt-inst$GLIBC_VER-6.so.$MAJOR.$MINOR ${D}${libdir}/libapt-inst.so
install -d ${D}${libdir}/apt/methods
install -m 0755 bin/methods/* ${D}${libdir}/apt/methods/
diff --git a/packages/apt/apt.inc b/packages/apt/apt.inc
index dbf5765205..283b80d662 100644
--- a/packages/apt/apt.inc
+++ b/packages/apt/apt.inc
@@ -2,7 +2,8 @@ DESCRIPTION = "Advanced front-end for dpkg."
LICENSE = "GPL"
SECTION = "base"
-SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz"
+SRC_URI = "${DEBIAN_MIRROR}/main/a/apt/apt_${PV}.tar.gz \
+ file://environment.patch;patch=1"
S = "${WORKDIR}/apt-${PV}"
inherit autotools gettext
@@ -12,4 +13,5 @@ EXTRA_AUTORECONF = "--exclude=autopoint,autoheader"
# Apt wants to know the glibc version by running a binary file, which will fail, so we have to tell configure which version to use
# Since I don't know the impliations of setting a wrong value I only provide one for angstrom, which uses glibc 2.5 (which claims to be 2.4)
# Koen - 20070327
-EXTRA_OECONF_angstrom += " ac_cv_glibc_ver=libc6.4"
+EXTRA_OECONF_append_angstrom = " ac_cv_glibc_ver=libc6.4"
+
diff --git a/packages/apt/apt_0.6.46.2.bb b/packages/apt/apt_0.6.46.2.bb
index 73285f37c3..24023f2a58 100644
--- a/packages/apt/apt_0.6.46.2.bb
+++ b/packages/apt/apt_0.6.46.2.bb
@@ -6,3 +6,6 @@ require apt-package.inc
FILES_${PN} += "${bindir}/apt-key"
apt-manpages += "doc/apt-key.8"
+
+PR = "r1"
+
diff --git a/packages/apt/files/environment.patch b/packages/apt/files/environment.patch
new file mode 100644
index 0000000000..5bea1a0130
--- /dev/null
+++ b/packages/apt/files/environment.patch
@@ -0,0 +1,13 @@
+Index: apt-0.6.46.2/buildlib/environment.mak.in
+===================================================================
+--- apt-0.6.46.2.orig/buildlib/environment.mak.in 2007-03-29 11:38:58.000000000 +0100
++++ apt-0.6.46.2/buildlib/environment.mak.in 2007-03-29 11:39:12.000000000 +0100
+@@ -62,7 +62,7 @@
+
+ # Shared library things
+ HOST_OS = @host_os@
+-ifneq ($(words $(filter linux-gnu gnu% %gnu,$(HOST_OS))),0)
++ifneq ($(words $(filter linux-gnu linux-gnueabi gnu% %gnu,$(HOST_OS))),0)
+ SONAME_MAGIC=-Wl,-soname -Wl,
+ LFLAGS_SO=
+ else